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I m p o r t a n t  P r e c a u t i o n s  f o r  U s e

2I m p o r t a n t  P r e c a u t i o n s  f o r  U s e

• For precautions related to machine design and wiring, please read the safety instructions in the manual for your 
machine.

• For details regarding the product warranty, please read the warranty information in the manual for your machine.

Safety Precautions

• The examples described in this document are provided for reference only and do not guarantee functionality. 
When implementing them, please verify the functionality and safety of the equipment or devices yourself before 
use.

• Available features and settings may vary depending on the product version you are using. Depending on the 
product version, settings, procedures, and screens may differ from those described in this document. In such 
cases, refer to your product manual or the software’s built-in help.

• Please note that the contents of this manual, including specifications, are subject to change without notice for 
improvement purposes.

• For information on connecting the software used in this manual to devices, refer to the manuals for each software 
and device.

• For more detailed information on the contents of this manual, please refer to the relevant manuals.

Note
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Te r m s

3T e r m s

This section explains the terms used in this document.
For terms not described here, refer to the manuals listed in the “Relevant Manuals” section.

DescriptionTerm

An open network that uses “TSN (Time-Sensitive Networking)”, which is an extension of the 
Ethernet standard, to ensure real-time control and handle information from other open networks 
simultaneously.

CC-Link IE TSN

A station that controls the entire network. This station can perform cyclic transmission and transient 
transmission with all stations.
In this document it refers to the MELSEC MX Controller.

Master station

A station that exchanges I/O signals (bit data) and I/O data (word data) with another station by 
cyclic transmission. A transient transmission is available.
In this document it refers to a drive unit manufactured by FASTECH Co., Ltd.

Remote station

An abbreviation for Process Data Object. A collection of the application objects transmitted 
periodically between multiple CANopen nodes.

PDO

Various data held by the CANopen-compatible device station.Object
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Manual numberManual name

SH-082641ENGMELSEC MX Controller MX-R Model User’s Manual

SH-082644ENGMELSEC MX Controller MX-R Model Programming Manual

SH-082634ENGMELSEC MX Controller MX-F Model User’s Manual

SH-082691ENGMELSEC MX Controller MX-F Model Programming Manual

SH-081215ENGGX Works3 Operating Manual

R e l e v a n t  M a n u a l s

4R e l e v a n t  M a n u a l s

The latest manuals, library files, and configuration/setup software for drive units manufactured by FASTECH 
Co., Ltd. are available for download from FASTECH Co., Ltd.’s website.
cltsn.fastech-motions.com/en

The latest PDF manuals are available from MITSUBISHI ELECTRIC Factory Automation Global website.
www.MitsubishiElectric.com/fa
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1. OVERVIEW
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This document explains the configuration steps to connect the MELSEC MX Controller MX-R Model*1 and 
a drive unit manufactured by FASTECH Co., Ltd. over CC-Link IE TSN.

In this document the MELSEC MX Controller MX-R Model is referred to as the controller.

By referring to this document and using engineering tools to configure network connections and create 
programs, you can:

(1) Connect various CC-Link IE TSN compatible devices (drive units, inverters, etc.)

Through the controller, you can connect to drive units and inverters compatible with CC-Link IE TSN. 
Therefore, the options for equipment selection expand when building or modifying equipment.

(2) With PLCopen® Motion Control FB, each drive unit can be controlled with a consistent user experience

You can program using Motion Control FB compliant with IEC 61131-3. Therefore, program 
specifications such as operation specifications and interface specifications are standardized regardless 
of a drive unit, allowing each drive unit to be controlled with a consistent user experience.

O v e r v i e w 7

O v e r v i e w1.1

*1: You can connect a drive unit manufactured by FASTECH Co., Ltd. to the MX-F Model using the same procedure.
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Below is the product lineup of drive units manufactured by FASTECH Co., Ltd. compatible with CC-Link IE 
TSN. For details on each product, please contact FASTECH Co., Ltd.

D r i v e  U n i t  M a n u f a c t u r e d  b y  F A S T E C H  C o . ,  L t d .

D r i v e  U n i t  M a n u f a c t u r e d  b y

FA S T E C H  C o . ,  L t d .

SpecificationItem

CC-Link IE TSN Class BCommunication protocol

1Gbps / 100MbpsCommunication speed

CiA402 Drive profile:
Cyclic synchronous position mode (CSP) / Profile position mode 
(PP) / Homing mode (HM)

Operating mode

IEEE1588 / IEEE802.1ASTime synchronization 
method

Synchronization 
method

Minimum 250 ㎲Communication cycle

Synchronous communication (CSP, PP, HM) / Asynchronous 
communication (PP, HM)

Network synchronous 
communication

Incremental typeEncoder type

1.2

Below are the product specifications for the drive units.

・Ezi-SERVO-CT

・Ezi-STEP-CT
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L i s t  o f  R e s t r i c t i o n s1.3

RestrictionItem

For the following models, always perform a home position return after turning servo ON.
Because this is an open-loop control system, the “Position actual value (Index: 6064h, Sub index: 
00h)” is not updated during servo OFF.
The follow up function uses the “Position actual value (Index: 6064h, Sub index: 00h)” to reflect 
motor rotation in the controller’s command; therefore, any motor rotation during servo OFF will 
cause a discrepancy between the controller’s command position and the motor’s actual position.
・ Ezi-STEP-CT

Follow up

Since the encoder is of the incremental type, the absolute position system cannot be used.Absolute position 
control

The home position switch (AbsSwitch) for MC_Home (OPR) cannot be used to transmit the dog 
signal to the drive unit.

Driver homing method

External signal high-accuracy input is not supported.Speed to positioning 
move control

Since the drive unit does not support Cyclic synchronous velocity mode (CSV), MC_MoveVelocity
(Speed Control) cannot be used.

Velocity control

Since the drive unit does not support Cyclic synchronous torque mode (CST), 
MC_TorqueControl(Torque control) cannot be used.

Torque control

Since only MELSERVO supports the pressure control, MCv_PressureControl (Pressure Control)
cannot be used.

Pressure control

Below are the limitations of motion control functions when the controller is connected to the drive unit. For 
details on each function, please refer to the controller manual.
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L i s t  o f  R e s t r i c t i o n s

RestrictionItem

Since the drive unit does not support “Positive torque limit value (Index: 60E0h, Sub index: 00h)” 
and “Negative torque limit value (Index: 60E1h, Sub index: 00h),” the following functions cannot be 
used.
・ AxisName.PrConst.TorqueLimit_Max (Torque Limit Maximum Value)
・ AxisName.PrConst.TorqueLimit_PositiveInitial (Positive Direction Torque Limit Initial Value)
・ AxisName.PrConst.TorqueLimit_NegativeInitial (Negative Direction Torque Limit Initial Value)
・ AxisName.Cd.TorqueLimit_Positive (Positive Direction Torque Limit Value)
・ AxisName.Cd.TorqueLimit_Negative (Negative Direction Torque Limit Value)
・ MCv_SetTorqueLimit (Torque Limit Value)

Torque limit

External signal high-accuracy input is not supported.External signal 
selection

External signal high-accuracy input is not supported.Touch probe

It is emulated as an MR-J5-G.Axis emulation

External signal high-accuracy input cannot be used for the clutch signal setting.Advanced synchronous 
control

Among this history data, the following data will always remain “0.”
・ Home cycle counter
・ Home ABS counter
・ Encoder multiple revolution position
・ Encoder 1 revolution position

Positioning data history

1.3
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S y s t e m  C o n f i g u r a t i o n

In this document, the explanation is based on the following system configuration.

Version used in 
this document

Supported versionModel name / SoftwareDevice

――R35BMain base module(1)

――R64PPower supply module(2)

“04”“01” or laterMXR500-256Controller(3)

“1.0”―Ezi-SERVO-CTDrive unit(4)

――EzM2-42L-AMotor(5)

“1.120A”“1.115V” or laterGX Works3Configuration PC(6)

“1.0.5.16”―Ezi-CT Manager

1.4

(6)(4)

(5)

USB cable

Ethernet cable

(3)(1) (2)
Ethernet cable
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Operation Check

Controller Settings

Drive Unit Settings

S e t u p  P r o c e d u r e 12

S e t u p  P r o c e d u r e1.5

This section describes the setup procedures to connect the controller and drive unit in the system 
configuration described above.
Follow the steps below to perform the setup and verify operation.

Create a program to verify that the controller and drive 
unit are correctly configured.
Operate the label to confirm that the motor operates 
properly.

Using the engineering tool, create the controller project, 
configure the unit parameters (communication method, 
connection destination), and set up motion control (axis 
parameters).

Using the engineering tool, configure the parameters of 
the drive unit.
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2. DRIVE UNIT SETTINGS
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2.1

P a r a m e t e r  S e t t i n g s

P a r a m e t e r  S e t t i n g s

14

This section explains the procedure for configuring the drive unit parameters using Ezi-CT Manager.
Before launching Ezi-CT Manager, turn on the power to the drive unit and connect it to the configuration PC 
via an Ethernet cable.

1. Start Ezi-CT Manager.

■Connection

2. Click the icon       at the top of the screen to open 

the “Device Scanner” window.



©Mitsubishi Electric Corporation

3. Click the [Start] button. After a short wait, the drive 

unit connected to the configuration PC will be 

displayed.

15

2.1

P a r a m e t e r  S e t t i n g s

P a r a m e t e r  S e t t i n g s

5. Once the connection between Ezi-CT Manager and the 

drive unit is established, the information will be 

displayed in the “LOG Message” window.

4. Select the drive unit shown in the window and click 

the [Connect] button.
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2.1

P a r a m e t e r  S e t t i n g s

P a r a m e t e r  S e t t i n g s

16

■Parameter Settings

2. Configure the parameters as appropriate for your 

environment.

When you have finished setting the parameters, click 

the [Store] button.

1. Click the icon      at the top of the screen to open 

the “Parameter manager” window.
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3. Click the [OK] button, then turn the power of the 

drive unit OFF and back ON.

17

2.1

P a r a m e t e r  S e t t i n g s

P a r a m e t e r  S e t t i n g s
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2.2

P o i n t s

P o i n t s

Here are the key points regarding the drive unit parameter settings. For detailed information on the 
parameters, please refer to the drive unit manual.

 The IP address can be set using the rotary switch on the drive unit. By setting the rotary switch to “00,” 
you can also configure it via “IP Address (Index: 2101h, Sub index: 01-04h).”

 When performing driver-based home position return, the initial value of “Homing method (Index: 6098h, 
Sub index: 00h)” is “0 (No Mode)” so please set it to a valid value. Also, set “Home offset (Index: 607Ch, 
Sub index: 00h)” to “0.” If a value other than “0” is set, the system may accelerate or decelerate abruptly 
upon completion of home position return.

 Set “Limit stop method (Index: 2003h, Sub index: 00h)” to “3 (Quick stop)” or “4 (Deceleration stop).” If a 
value other than “3” or “4” is set, the drive unit will not stop even when a hardware stroke limit is detected.
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3. CONTROLLER SETTINGS
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1. Start GX Works3.

Select [Tool] → [Profile Management] → [Register] 

from the menu bar.

2. Choose the profile and click the [Register] button.

20

3.1

P r e p a r a t i o n

P r e p a r a t i o n

Register the drive unit profile (*.zip) in GX Works3. Since you cannot register the profile while a project is 
open, please do this before creating a project.
The profile can be downloaded from FASTECH Co., Ltd.’s website.
cltsn.fastech-motions.com/en

3. Click the [OK] button.



©Mitsubishi Electric Corporation 21

3.2

C r e a t e  P r o j e c t

C r e a t e  P r o j e c t

Create a controller project in GX Works3.

1. Create a new project.

Select [Project] → [New] from the menu bar.

2. In the “New” window, choose the following items 

and click the [OK] button.

• Series: MX Controller

• Type/Model: MXR500

• Number of Axis: 256 axes

• Built-in Network Type: Ethernet + CC-Link IE TSN

• Program Language: ST
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3.2

C r e a t e  P r o j e c t

C r e a t e  P r o j e c t

4. In the “Enable User Authentication” window, enter 

the username and password, then click the [OK] 

button.

3. Register the username and password used to log in to 

the project. In the next window, click the [Yes] button.
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3.2

C r e a t e  P r o j e c t

C r e a t e  P r o j e c t

6. In the next window, click the [OK] button.5. In the next window, enter the file name, then click the 

[Save] button to save the project.
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3.2

C r e a t e  P r o j e c t

C r e a t e  P r o j e c t

8. Click [Edit] → [Parameter] → [Fix] from the menu bar.7. Double-click [Navigation] → [Module Configuration], 

and set up the module configuration diagram.

Configure the necessary units according to your 

system setup.

• Main Base: R35B

• Power Supply: R64P

• MX Controller: MXR500-256

Drag ＆ Drop
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3.2

C r e a t e  P r o j e c t

C r e a t e  P r o j e c t

9. In the next window, click the [Yes] button.
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3.3

M o d u l e  P a r a m e t e r  S e t t i n g s

M o d u l e  P a r a m e t e r  S e t t i n g s

26

Set the master station parameters in the [Required Settings] of the [Module Parameter (CC-Link IE TSN)].

1. Double-click [Navigation] → [Parameter] → [MXR500-

256] → [Module Parameter (Port 1/2: CC-Link IE TSN)] 

→ [Module Parameter (CC-Link IE TSN)].

2. The “Module Parameter” window opens.

Select [Setting Item List] → [Required Settings], and 

configure the following items.

• Network No.: 1 (Default)

• IP Address: 192.168.4.253 (Default)

• Subnet Mask: 255.255.255.0

■Required Settings
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3.3

M o d u l e  P a r a m e t e r  S e t t i n g s 27

M o d u l e  P a r a m e t e r  S e t t i n g s

Drag ＆ Drop

2. The “CC-Link IE TSN Configuration” window opens.

From [Module List] → [CC-Link IE TSN Module

(FASTECH Co. Ltd)] → [Closed-loop Step Drive], 

select [Ezi-SERVO-CT] and drag and drop it.

1. Select [Setting Item List] → [Basic Settings], then 

double-click [Detailed Setting] in the [Network 

Configuration Settings].

Set the network configurations in the [Basic Settings] of the [Module Parameter (CC-Link IE TSN)].

■Basic Settings
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3.3

M o d u l e  P a r a m e t e r  S e t t i n g s 28

M o d u l e  P a r a m e t e r  S e t t i n g s

3. Set the [IP Address] for [Ezi-SERVO-CT]. 4. Set the [Network Synchronous Communication] for 

[Ezi-SERVO-CT] to “Synchronous.”

Point

Match the fourth octet of the IP address to the rotary 

switch setting of the drive unit [Ezi-SERVO-CT].
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5. Double-click [Detail Setting] in the [PDO Mapping Setting] for [Ezi-SERVO-CT], and select a PDO mapping pattern. 

For each link device, choose the option specified in the table below.

3.3

M o d u l e  P a r a m e t e r  S e t t i n g s 29

M o d u l e  P a r a m e t e r  S e t t i n g s

Pattern nameLink device

1st TPDO (CSP Mode)RWr

1st RPDO (CSP Mode)RWw
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3.3

M o d u l e  P a r a m e t e r  S e t t i n g s 30

M o d u l e  P a r a m e t e r  S e t t i n g s

6. Map the objects required for motion control to PDO.

Configure the TPDO and RPDO to match the table below.

NameData typeSub indexIndex

Watchdog counter UL 1U16011D02

StatuswordU16006041

Modes of operation displayI8006061

Error codeU1600603F

Position actual valueI32006064

Digital inputsU320060FD

NameData typeSub indexIndex

Watchdog counter DL 1U16011D01

ControlwordU16006040

Modes of operationI8006060

Target positionI3200607A

■TPDO

■RPDO
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7. After completing the TPDO and RPDO settings, click 

the [OK] button.

■TPDO

■RPDO

3.3

M o d u l e  P a r a m e t e r  S e t t i n g s 31

M o d u l e  P a r a m e t e r  S e t t i n g s

8. Click [Close with Reflecting the Setting].
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9. If the following warning appears, click the [Yes] button.

3.3

M o d u l e  P a r a m e t e r  S e t t i n g s 32

M o d u l e  P a r a m e t e r  S e t t i n g s

10. In the “Module Parameter” window, click the [Apply] 

button.
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11. If the following window appears, click the [Create] 

button to assign the drive unit to the axis.

3.3

M o d u l e  P a r a m e t e r  S e t t i n g s 33

M o d u l e  P a r a m e t e r  S e t t i n g s

12. In the next window, click the [OK] button.
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2. The “Axis Parameter Setting” window opens.

Select [Setting Item List] → [Real Drive Axis] → [Basic 

Parameter] → [Object Data], then click the [...] button 

next to any item.

34

3.4

A x i s  P a r a m e t e r  S e t t i n g s

A x i s  P a r a m e t e r  S e t t i n g s

Configure the drive unit’s axis parameters in the [Motion Setting].

1. Double-click [Navigation] → [Motion Setting] → [Axis] 

→ [Axis0001].
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5. A confirmation dialog will appear asking whether to 

set the generic default values. Click the [Yes] button.

The [Object Data] column will be partially cleared.

35

3.4

A x i s  P a r a m e t e r  S e t t i n g s

A x i s  P a r a m e t e r  S e t t i n g s

3. In the “Object Data Setting” window, click the 

[Restore the Default Settings] button.

4. A confirmation dialog will appear asking whether to 

set the default data. Click the [Yes] button.
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3.4

A x i s  P a r a m e t e r  S e t t i n g s

A x i s  P a r a m e t e r  S e t t i n g s

6. Clear any object data settings that are not supported 

by the drive unit. Delete the values in the [Object Data] 

column for rows where the [Object] column is blank.

7. Once you have completed the settings, click the [OK] 

button.

Click ＆ Delete
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3.4

A x i s  P a r a m e t e r  S e t t i n g s

A x i s  P a r a m e t e r  S e t t i n g s

8. Select [Setting Item List] → [Real Drive Axis] → [Basic 

Parameter] → [Absolute Position Control Setting], and 

set it to “0: Disable Absolute Position System.”

9. Select [Setting Item List] → [Real Drive Axis] → [Basic 

Parameter] → [Velocity Bias Value], and set the velocity 

bias value appropriate for the motor you will use.
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3.4

A x i s  P a r a m e t e r  S e t t i n g s

A x i s  P a r a m e t e r  S e t t i n g s

Point

Set [Velocity Bias Value] using the motor specifications. 

In this document, the value is calculated from the 

encoder resolution and the motor torque characteristics.

Velocity Bias Value [pulse/s]=

Encoder resolution × Minimum rotational speed ÷ 60
10000 pulse/r 10 r/min (*1)

≒ 1700 pulse/s

*1: Refer to the torque characteristic graph below.

(Image source: cltsn.fastech-motions.com/upload/smarteditor
/goods/20251229141549_1737.jpg)

10.Click the [Apply] button.
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4. OPERATION CHECK
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ContentClassData typeLabel nameCategory

Axis1 VelocityVARFLOAT [Double Precision]leJogVelocityLocal

Axis1 AccelerationVARFLOAT [Double Precision]leJogAccelerationLocal

Axis1 DecelerationVARFLOAT [Double Precision]leJogDecelerationLocal

Axis1 JerkVARFLOAT [Double Precision]leJogJerkLocal

Axis1 JOG Forward commandVARBitbJogForwardCmdLocal

Axis1 JOG Reverse commandVARBitbJogReverseCmdLocal

4.1

C r e a t e  P r o g r a m

C r e a t e  P r o g r a m

40

Verify that the controller and drive unit are properly connected over CC-Link IE TSN.
Create a JOG operation program for motion control, perform the connection test by confirming that JOG 
operation (motion control) runs correctly.

1. Double-click [Navigation] → [Program] → [Scan] → 

[MAIN] → [ProgPou] → [Local Label].

2. Create the local labels necessary for operation check.
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4.1

C r e a t e  P r o g r a m

C r e a t e  P r o g r a m

41

3. Double-click [Navigation] → [Label] → [Global Label] 

→ [Global].

ContentClassData typeLabel nameCategory

Servo ON requestVAR_GLOBALBitG_bServoONGlobal

Servo OFF requestVAR_GLOBALBitG_bServoOFFGlobal

Servo ON operatingVAR_GLOBALBitG_bAllPowerBusyGlobal

JOG Forward request VAR_GLOBALBitG_bJogForwardReqGlobal

JOG Reverse requestVAR_GLOBALBitG_bJogReverseReqGlobal

JOG OperatingVAR_GLOBALBitG_bJogBusyGlobal

JOG ErrorVAR_GLOBALBitG_bJogErrorGlobal

4. Create the global labels necessary for operation check.
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4.1

C r e a t e  P r o g r a m

C r e a t e  P r o g r a m

42

5. Double-click [Navigation] → [Program] → [Scan] → 

[MAIN] → [ProgPou] → [ProgramBody].

The ST editor opens.

6. Write a program to check that motion control is ready.

After the controller is powered on, when the following 

signals are turns ON, set “Servo ON request 

(G_bServoON)” to ON.

• PLC READY (MotionSystem.Cd.SequenceReady)

• Built-in Motion Ready [X20]

Point

In this document the program will be written in ST 

language, but it can also be written in other languages.
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4.1

C r e a t e  P r o g r a m

C r e a t e  P r o g r a m

43

7. Display the “POU List” tab in the “Element Selection” 

window.

Drag and drop [MCv_AllPower] from [Motion Control 

Function / Function Block] → [Administrative] into 

the ST editor, and insert the FB (MCv_AllPower).

8. When the “FB Instance Name” window appears, click 

the [OK] button to accept the defaults and define the 

FB (MCv_AllPower_1).

The FB (MCv_AllPower_1) is displayed in the ST editor 

as shown below.Drag ＆ Drop
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4.1

C r e a t e  P r o g r a m

C r e a t e  P r o g r a m

44

Point

Jerk is the chronological change ratio of the 

acceleration or the deceleration.

9. Describe the FB (MCv_AllPower_1).

When “Servo ON request (G_bServoON)” is ON, 

execute the FB.

Set the arguments of the FB as shown below. Any 

arguments other than those listed below are not 

required, please delete them.

■ FB (MCv_AllPower_1) arguments

• Enable: TRUE

• ServoON: G_bServoON

• Busy: G_bAllPowerBusy

10.Write a program to configure the velocity, acceleration, 

deceleration, and jerk for JOG operation.

In this document, they are set as follows:

■ Velocity settings for JOG operation

• Velocity: 3000 [pulse/s]

• Acceleration: 2000 [pulse/s2]

• Deceleration: 2000 [pulse/s2]

• Jerk: 0 [pulse/s3]
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Drag ＆ Drop
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12.Drag and drop [MCv_Jog] from [Element Selection] → 

[Motion Control Function / Function Block] → [Motion -

Individual] into the ST editor, and insert the FB 

(MCv_Jog).

11.Write an interlock program that prevents forward 

and reverse commands from being executed 

simultaneously when performing JOG operation.
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13.When the “FB Instance Name” window appears, click the [OK] button to accept the defaults and define the FB 

(MCv_Jog_1). The FB (MCv_Jog_1) is displayed in the ST editor as shown below.
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14.Describe the FB (MCv_Jog_1).

Execute the FB when either “JOG Forward request (G_bJogForwardReq)” or “JOG Reverse request 

(G_bJogReverseReq)” turns ON.

Set the arguments of the FB as shown below. Any arguments other than those listed below are not required, 

please delete them.

■ FB (MCv_Jog_1) arguments

• Axis: Axis0001.AxisRef

• JogForward: bJogForwardCmd

• JogBackward: bJogReverseCmd

• Velocity: leJogVelocity

• Acceleration: leJogAcceleration

• Deceleration: leJogDeceleration

• Jerk: leJogJerk

• Busy: G_bJogBusy

• Error: G_bJogError

4.1

C r e a t e  P r o g r a m
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15.After creating the program, select [Convert] → 

[Rebuild All] from the menu bar to perform a full 

conversion of the program.

16. In the “Rebuild All" window, select “Create Execution 

Programs after Conversion” and click the [OK] button.

17. If no errors are reported in the “Progress” window, 

the full conversion is complete.
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Perform a functional check to confirm that the controller and drive unit communicate correctly over CC-Link 
IE TSN. Also verify that the drive unit performs JOG operation when it receives the command signal.

4.2
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1. Click [Online] → [Write to PLC] from the menu bar.

Make sure to connect the controller and the 

configuration PC with an Ethernet cable beforehand.

2. Click the [Select All] button, then click the [Execute] 

button to write the parameters to the controller.

Point

After the parameter writing is complete, reset the 

controller, or turn the power off and then on again.
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3. Connect the controller and the drive unit with an 

Ethernet cable.

Check that the controller’s [D LINK] LED is lit to 

ensure that network communication has been 

established.

4.2

O p e r a t i o n  C h e c k
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Point

If the LED is not lit, please refer to the following.

「MELSEC MX Controller MX-R Model User’s Manual 

(SH-082641ENG)」

… Chapter 17 TROUBLESHOOTING

4. From the menu bar, click [View] → [Docking Window] 

→ [Watch 1] to display the “Watch 1” window.
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5. Register the created global labels in the “Watch 1” 

window.

7. From the menu bar, click [Online] → [Motion Monitor] 

→ [Axis Monitor] to display the “Axis Monitor” window.

6. In the “Watch 1” window, click [Start Watching] to 

begin monitoring.
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8. Switch the controller to RUN.

When motion control preparation is complete, “Servo ON request (G_bServoON)” will be set TRUE and the FB 

(MCv_AllPower_1) will be executed. Confirm that “Servo ON operating (G_bAllPowerBusy)” is TRUE and that the 

[Axis Status] is “4:Standstill.” Once the FB (MCv_AllPower_1) completes successfully, Axis 1 will turn the servo 

ON state.
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9. In the “Watch 1” window, set “JOG Forward request (G_bJogForwardReq)” or “JOG Reverse request 

(G_bJogReverseReq)” to TRUE to execute the FB (MCv_Jog_1).

Confirm that “JOG Operating (G_bJogBusy)” is TRUE and that the [Axis Status] is “6:ContinuousMotion.” 

The FB (MCv_Jog_1) will operate normally, and the motor will perform a JOG operation.

10.This completes the operation check.
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App.1

E x t e r n a l  S i g n a l  S e t t i n g s

E x t e r n a l  S i g n a l  S e t t i n g s

This explains how to use external signals connected to a drive unit in the motion system.
You can make those external signals available to the motion system by registering them as labels in the 
“Network Label Setting.”

1. In GX Works3, double-click [Navigation] → [Parameter] → [MXR500-256] → [Module Parameter (Port 1/2: CC-Link IE 

TSN)] → [Network Label Setting] to open the “Network Label Setting” window.

2. Check the [Labeling target] box for the data corresponding to the object “Digital inputs,” then click the [Create Label] 

button.

■ How to create network labels
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3. Click the [Yes] button to generate the network labels in the Global Labels.

4. Double-click [Navigation] → [Lablel] → [Global Label] → [NW+Global1] to open the “NW+Global1” window.

5. Check the “Access from External Device” checkbox for the generated network label.

E x t e r n a l  S i g n a l  S e t t i n g sApp.1
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6. Assign the network-labeled “Digital inputs” to the axis upper and lower limit signals.

Double-click [Navigation] → [Motion Setting] → [Axis] → [Axis0001] to open the “Axis Parameter Setting” window.

7. In [Setting Item List] → [Real Drive Axis] → [Limit Parameter] → [Upper Limit Signal] → [Target], click the [...] button.

E x t e r n a l  S i g n a l  S e t t i n g sApp.1
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8. In the “Target Setting” window, configure the following items and then click the [OK] button.

E x t e r n a l  S i g n a l  S e t t i n g s

SettingItem

LabelSource Type

Ezi_SERVO_CT_001_DigitalInputs.1Source

9. Similarly, configure the following items for the [Lower Limit Signal].

SettingItem

LabelSource Type

Ezi_SERVO_CT_001_DigitalInputs.0Source

10.This completes the setup.

App.1
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Tr o u b l e s h o o t i n g

If the operation checks described in this document do not result in correct operation, please refer to the 
manuals below.

「MELSEC MX Controller MX-R Model User’s Manual (SH-082641ENG)」
… Chapter 17 TROUBLESHOOTING

「MELSEC MX Controller MX-F Model User’s Manual (SH-082634ENG)」
… Chapter 18 TROUBLESHOOTING

App.2



BCN-89999-9770E-A(2605)

For safe use

• To use the products given in this publication properly, always read 
the relevant manuals before use.

• All other company names and product names used in this document 
are trademarks or registered trademarks of their respective companies.

• Trademark symbols such as “ ” and “®” might be omitted in 
this document.
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