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SAFETY PRECAUTIONS 
(Read these precautions before using this product.) 
Before using this solution, please read this guide and the relevant manuals listed in this guide carefully and pay full 
attention to safety to handle the product correctly. If the device is used in a manner not specified by the manufacturer, 
the protection provided by the device may be impaired. 
The precautions given in this guide are concerned with this solution only. 

In this guide, the safety precautions are classified into two levels: "  WARNING" and "  CAUTION". 

 WARNING 
Indicates that incorrect handling may cause hazardous conditions, resulting in death or severe 
injury. 

 CAUTION 
Indicates that incorrect handling may cause hazardous conditions, resulting in minor or 
moderate injury or property damage. 

Under some circumstances, failure to observe the precautions given under "  CAUTION" may lead to serious 
consequences. 
Observe the precautions of both levels because they are important for personal and system safety. 
Make sure that the end users read this guide and then keep the guide in a safe place for future reference. 
This guide does not cover all safety precautions for each product. Please read the manual for each product before use. 
 
[Design Precautions] 

 WARNING 

● For the operating status of each station after a communication failure, refer to the manual of each network. 
Incorrect output or malfunctions due to a communication failure may result in an accident. 

● In particular, when a remote programmable controller is controlled by an external device, immediate action cannot 
be taken if a problem occurs in the programmable controller due to a communication failure. To prevent this, 
configure an interlock circuit in the program and determine corrective actions to be taken between the external 
device and the CPU module in case of a communication failure. 

● When changing data in the programmable controller or controlling the status of the programmable controller 
during operation from a personal computer, configure an interlock circuit outside the programmable controller 
system so that the entire system operates safely. Additionally, for online changes from peripheral devices to the 
PLC CPU, establish procedures for handling communication failures that may occur due to issues such as poor 
cable connections. 

● If a communication cable is disconnected, the network may become unstable, resulting in communication failures 
on multiple stations. Configure an interlock circuit in the program to ensure that the entire system operates safely 
even if communication fails. Incorrect output or malfunctions due to a communication failure may result in an 
accident. 

 

 CAUTION 

● While settings are being applied, do not perform any operations that forcibly turn off the power of the personal 
computer running this solution. If the power is forcibly turned off while any settings are being applied, data may 
become undefined. In such cases, the settings must be configured and applied again. In addition, this may cause 
malfunctions in the devices used with this solution. 

 
  



Critical Moments Analytics Solution Introduction Guide 

 

 2 / 106  
BCN-89796-0228-A 

[Security Precautions] 

 WARNING 

● To maintain the security (confidentiality, integrity, and availability) of this product and the system against 
unauthorized access, denial-of-service (DoS) attacks, computer viruses, and other cyberattacks from external 
devices via the network, take appropriate measures such as firewalls, virtual private networks (VPNs), and 
antivirus solutions. 

 

[Wiring Precautions] 

 CAUTION 

● Place the cables to be connected to the built-in Ethernet port of the personal computer or the Ethernet adapter in 
a duct or clamp them. If not, dangling cables may swing or be inadvertently pulled, which can damage the cables 
or cause malfunctions due to poor connections. 

● When disconnecting the cable from the built-in Ethernet port of the personal computer or the Ethernet adapter, do 
not pull the cable by the cable part. Pulling the cable connected to the built-in Ethernet port of the personal 
computer or the Ethernet adapter may damage the cables or cause malfunctions due to poor connections. 

● Check the interface type and correctly connect the cable. Incorrect wiring (connecting the cable to an incorrect 
interface) may cause failure of the module and external device. 

● Prevent foreign matter such as dust or wire chips from entering the personal computer. Such foreign matter can 
cause a fire, failure, or malfunction. 

● Securely connect communication cables to the built-in Ethernet port of the personal computer or the Ethernet 
adapter. After connecting them, check for any lifting. 

● Individually ground the personal computer with a ground resistance of 100 ohms or less. Failure to do so may 
result in malfunction. 

 
[Precautions when using MELSOFT VIMA in China] 

 CAUTION 

● Some characters defined in GB 18030-2022 cannot be used. 

 

[Precautions for installation] 

● Use only the default folder as the installation folder. 
If any operation other than that described above is performed, MELSOFT VIMA may not operate properly. For 
example, characters are not displayed on MELSOFT VIMA. 

 

[Precautions for a file saving destination] 

● Use only alphanumeric characters for the name of a folder and file specified when a file is saved or opened in 
MELSOFT VIMA. Observe the same rule when changing a saved file name. 
If any other character is used, MELSOFT VIMA may not operate properly. For example, saving processing is 
canceled. 

 
  



Critical Moments Analytics Solution Introduction Guide 

 

 3 / 106  
BCN-89796-0228-A 

CONDITIONS OF USE FOR THE PRODUCT 

 

 
 

INTRODUCTION 
This document is an introduction guide for Critical Moments Analytics Solution. 
Follow the procedures described in this document to introduce Critical Moments Analytics Solution. 
For the operating method after the introduction, refer to the user's manual*1 of Critical Moments Analytics Solution. 
*1: The user's manual can be opened by performing either of the following operations in MELSOFT VIMA. 

• Click "Open manual" on the top screen. 

 

• Select [Help] → [Open manual] in the menu. 
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RELEVANT MANUALS 
The following lists the manuals relevant to this solution. 
 
■Mitsubishi Electric Corporation 

Manual name [manual number] Description 

Critical Moments Analytics Solution Introduction 
Guide 

[BCN-89796-0228] (this guide) 

Overview, system configuration, and introduction procedure 
of Critical Moments Analytics Solution 

Critical Moments Analytics Solution User's 
Manual 

[BCN-89796-0234] 

MELSOFT VIMA, procedures from startup to operation, and 
troubleshooting of Critical Moments Analytics Solution 

GX Works3 Operating Manual 

[SH-081215ENG] 

System configuration, parameter settings, and operation 
methods for the online function in GX Works3 

MELSEC iQ-R Motion Module User's Manual 
(Startup) 

[IB-0300406ENG] 

Specifications, procedures before operation, system 
configuration, and wiring of the Motion module 

MELSEC iQ-R Motion Module User's Manual 
(Application) 

[IB-0300411ENG] 

Functions, I/O signals, variables, labels, programming, and 
troubleshooting of the Motion module 

MELSEC iQ-R Motion Module User's Manual 
(Network) 

[IB-0300426ENG] 

Functions, parameter settings, troubleshooting, and buffer 
memory of CC-Link IE TSN 

Motion Control Setting Function 

[MCSHELP1252] 

System configuration, function description, operation 
methods, and programming of the motion control setting 
function 

MELSEC MX Controller MX-R Model User's 
Manual 

[SH-082641ENG] 

Procedures before operation, specifications, devices, 
memory, functions, parameters, and troubleshooting of the 
controller 
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■ViSCO Technologies Corporation 
The latest manuals for products manufactured by ViSCO Technologies Corporation can be downloaded from the 
website of ViSCO Technologies Corporation. 
https://www.visco-tech.com/english/ 

Manual name [manual number] Description 

Flash Light Controller User's Manual MVTFC1-
0448-00 

[MANTMFC1-EN] 

Handling method of the flash light controller 

Flash Light Controller MVTFC1-0448-00 Hardware 
Guide 

[MANHMFC1-EN] 

Product specifications, setting methods, description of 
each part, connections and settings, and troubleshooting 
of the flash light controller 

High-Brightness LED Light User's Manual HB2-
T2612W0-3F / HB2-T5012W0-5F 

[MANTHB2-EN-1_0-3F04] 

Handling method of the high-brightness LED light 

High-Brightness LED Light User's Manual 

[MANTHB2-EN-1_0-IC01] 

Handling method of the high-brightness LED light 
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TERMS 
Unless otherwise specified, this guide uses the following terms. 

Term Description 

CC-Link IE TSN An open network that uses "TSN (Time-Sensitive Networking)", which is an extension of 
the Ethernet standard, to ensure real-time control and handle information from other 
open networks simultaneously. 

CC-Link IE TSN Class A group of devices and switching hubs compatible with CC-Link IE TSN, classified 
according to the functions and performance by the CC-Link Partner Association. 

For CC-Link IE TSN Class, refer to the CC-Link IE TSN Installation Manual (BAP-
C3007ENG-001) published by the CC-Link Partner Association. 

Focal length Distance from the center of the lens to the imaging element. 

Global label A label that is valid for all the program data when multiple program data are created in 
the project. 

There are two types of global labels: module specific labels (module labels), which are 
automatically generated by GX Works3, and optional labels, which can be created for 
any specified device. 

GX Works3 The product name of the software package for MELSEC programmable controllers. 

Imaging data Data of the camera images collected. 

Label A variable consisting of a specified string used in I/O data or internal processing. 

Link device A device (RX, RY, RWr, or RWw) in a module on CC-Link IE TSN. 

Local station A station that performs cyclic transmission and transient transmission with the master 
station and other local stations. 

Master station A station that controls the entire network. This station can perform cyclic transmission 
and transient transmission with all stations. Only one master station can be used in a 
network. 

Motion control station A device station that exchanges cyclic data through slave labels and motion control. 

Multicast mode A communication mode used to send cyclic data to multiple stations. 

Remote station A station that performs cyclic transmission of I/O signals in bits and I/O data in words. 
Transient transmission can be performed as well. 

TSN control cycle Communication cycle for the CC-Link IE TSN master station. 

TSN control data Link device data for the master station and device stations of CC-Link IE TSN. 

Unicast mode A communication mode used to send cyclic data to one station. 

USB3 Vision One of the interface standards for industrial cameras. 

Working distance Distance from the subject to the front of the lens. 
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GENERIC TERMS AND ABBREVIATIONS 
Unless otherwise specified, this guide uses the following generic terms and abbreviations. 

Generic term/abbreviation Description 

Control port A generic term for an imaging control port and lighting control port of the lighting 
controller. 

CPU module A generic term for MX Controller and RCPU. 

Device station A generic term for a local station and remote station on CC-Link IE TSN. 

Engineering tool A generic term for GX Works3 and MELSOFT VIMA. 

High-intensity lighting An abbreviation for the high-brightness LED light manufactured by ViSCO 
Technologies Corporation (HB2-T5012W0-5F, HB2-C22X1W0-IC). 

Lighting controller An abbreviation for the flash light controller manufactured by ViSCO Technologies 
Corporation (MVTFC1-0448-00). 

Motion module A generic term for RD78G4, RD78G8, RD78G16, RD78G32, RD78G64, RD78GHV, 
and RD78GHW modules. 

MX Controller A generic term for MXR300-16, MXR300-32, MXR300-64, MXR500-128, and 
MXR500-256 controllers. 

RWr An abbreviation for a remote register of the link device. This refers to 16-bit (1-
word) data input from a device station to the master station. (Not applicable for 
some local stations.) 

RWw An abbreviation for a remote register of the link device. This refers to 16-bit (1-
word) data output from the master station to a device station. (Not applicable for 
some local stations.) 

RX An abbreviation for remote input of the link device. This refers to bit data input from 
a device station to the master station. (Not applicable for some local stations.) 

RY An abbreviation for remote output of the link device. This refers to bit data output 
from the master station to a device station. (Not applicable for some local stations.) 

USB camera An industrial camera that supports USB3 Vision. 
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1. OVERVIEW  
1.1. Overview of Critical Moments Analytics Solution 

1. OVERVIEW 
This chapter provides an overview of Critical Moments Analytics Solution. 
 

1.1. Overview of Critical Moments Analytics Solution 
Critical Moments Analytics Solution supports the resolution of abnormalities and troubles that occur when starting up 
equipment that performs high-speed and high-intensity operation. 
With the analysis support software "MELSOFT VIMA", the imaging data of the target equipment operation captured by 
cameras can be collected. In addition, the control data of the target equipment can be collected via the CC-Link IE TSN 
network. 
The collected imaging data and the TSN control data can be displayed, played, and digitalized in MELSOFT VIMA. This 
supports analysis of the abnormalities and troubles. 
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1. OVERVIEW  
1.2. Configuration of Critical Moments Analytics Solution 

1.2. Configuration of Critical Moments Analytics Solution 
The following shows the configuration of this solution. 
For details on the components, refer to "3 SYSTEM CONFIGURATION". 

 
 

Device/software Role 

Personal 
computer 

MELSOFT VIMA Configuring the settings of the solution, collecting data, and analyzing data 

GX Works3 ・Configuring the settings of the Motion module or MELSEC MX Controller 

・Creating the imaging control program 

Motion module or MELSEC 
MX Controller 

・Controlling the target equipment 

・Turning on/off the imaging control signal of the lighting controller 

Servo amplifier Controlling the target equipment 

Lighting controller Controlling the camera imaging and lighting 

Industrial camera Imaging of the target equipment 

High-intensity lighting Lighting up the target equipment (Brief bright light is emitted in synchronization with 
the camera imaging.) 
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1. OVERVIEW  
1.3. Features of Critical Moments Analytics Solution 

1.3. Features of Critical Moments Analytics Solution 
■Easy settings in MELSOFT VIMA 

Settings of each device such as the camera and lighting that are necessary for imaging can be configured in 
MELSOFT VIMA. 
Because the camera image can be monitored in MELSOFT VIMA in real time, you can configure the imaging 
environment settings while checking the status of the target equipment. 

 

 
■Collection of high-quality imaging data 

This solution allows the highly precise synchronization of the camera imaging and the flash timing of the lighting 
using the lighting controller. A clear image can be captured even for the equipment that performs high-speed and 
high-precision operation. High-quality images of operation can be captured without any motion blur even during 
trouble occurrences, making it easier to check the differences from normal conditions and identify the locations of 
abnormalities. 
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1. OVERVIEW  
1.3. Features of Critical Moments Analytics Solution 

■Control of imaging timing 
Turning on or off the imaging control signal of the lighting controller from the master station (such as the Motion 
module or MX Controller) enables the control of the imaging timing of the camera and the lighting timing. 
Because the lighting controller supports the CC-Link IE TSN network synchronous communication, it can operate in 
synchronization with the cycle of the master station. This allows starting the imaging and turning on the lighting 
according to the operation timing of the target equipment, and thus the high-precision imaging data can be acquired. 

 
 
■Linkage of imaging data and TSN control data 

The control data of the target equipment and the imaging data of its operation can be played and checked in 
conjunction, allowing you to identify the locations and timings of abnormality occurrences from images and graphs. 
Any type and format can be set for the control data to be displayed. 
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1. OVERVIEW  
1.3. Features of Critical Moments Analytics Solution 

■Image measurement of imaging data 
Edge points can be detected from the collected imaging data. The detected edge points can be digitalized and 
displayed in graphs, allowing you to analyze the data quantitatively. 
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2. PERFORMANCE SPECIFICATIONS 

2. PERFORMANCE SPECIFICATIONS 
This chapter describes the performance specifications of this solution. 
 

2.1. Maximum Number of Devices 
The following shows the maximum number of devices to be used in this solution. 

Device Maximum number of 
devices 

Description 

Camera 4 Up to four cameras can be connected to a single 
lighting controller. 

Lighting controller 1 A single lighting controller can be connected to 
MELSOFT VIMA. 

High-intensity lighting 4*1 Up to four units of high-intensity lighting*1 can be 
connected to a single lighting controller. 

Motion module or MELSEC MX 
Controller MX-R model 

1 Either a single Motion module or MELSEC MX 
Controller MX-R model that controls the target 
equipment can be used. 

*1: When a branch cable is used, two units of lighting can be connected to a lighting control port of 1 CH, thus up to 
eight units of lighting can be connected. 

 

2.2. Performance of TSN Control Data Collection 
The following shows the performance of TSN control data collection. 

Item Description 

Channel Available number of ports 1 

Link device data access Maximum device points RX 16384 points (2 K bytes) 

RY 16384 points (2 K bytes) 

RWr 8192 points (16 K bytes) 

RWw 8192 points (16 K bytes) 

Maximum number of stations ・For Motion module: 121 

・For MELSEC MX Controller MX-R model: 253 

Minimum communication cycle*1 125 μs 

*1: The minimum communication cycle supported by this solution. The minimum communication cycle of CC-Link IE 
TSN for each device varies depending on the model. For details, refer to the manual of each device. 
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3. SYSTEM CONFIGURATION  
3.1. Configuration Example 

3. SYSTEM CONFIGURATION 
This chapter describes the system configuration of this solution. 
 

3.1. Configuration Example 
The following shows a system configuration example for this solution. 
The system configuration differs depending on the number of devices to be used and the network configuration. This 
section shows an example for the following case. 
• Industrial camera: 2 units 
• High-intensity lighting: 2 units 
• Network configuration: Star topology 

 
 

No. Item 

(1) MELSEC iQ-R series Motion module/MELSEC MX Controller MX-R model 

(2) Servo amplifier 

(3) Switching HUB*1 

(4) Lighting controller 

(5) 
Personal computer*2 GX Works3 

MELSOFT VIMA 

(6) High-intensity lighting 

(7) Industrial camera (USB camera) 

*1: It is not required for a line topology. For details of the network configuration, refer to "3.4 Network Configuration". 

*2: GX Works3 and MELSOFT VIMA can be installed and used on different personal computers. 

 
  



Critical Moments Analytics Solution Introduction Guide 

 

 18 / 106  
BCN-89796-0228-A 

3. SYSTEM CONFIGURATION  
3.2. Components 

3.2. Components 
This section describes the details of the components. 
 

3.2.1. Programmable controller system 

MELSEC iQ-R series Motion modules and MELSEC MX Controller MX-R models can be used. 
The following shows the models and firmware versions that can be used as the master station. 

Master station Model Firmware version*1 

MELSEC iQ-R series 
Motion module 

RD78G4, RD78G8, RD78G16, RD78G32, RD78G64, 
RD78GHV, RD78GHW 

"26" or later 

MELSEC MX Controller 
MX-R model 

MXR300-16, MXR300-32, MXR300-64, MXR500-128, 
MXR500-256 

"05" or later 

*1: For how to check the firmware version, refer to the manual of each model. 
 

3.2.2. Servo amplifier 

Servo amplifiers that support CC-Link IE TSN can be used. 
For details, refer to the manual of each servo amplifier. 
 

3.2.3. Lighting controller 

The following shows the lighting controller that can be used. 

Model Manufacturer 

MVTFC1-0448-00 ViSCO Technologies Corporation 

 

3.2.4. Personal computer 

Personal computers that satisfy the operating environment of the engineering tool can be used. 
• For the operating environment of MELSOFT VIMA, refer to "3.3.1 Operating environment". 
• For the operating environment of GX Works3, refer to "GX Works3 Operating Manual". 
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3. SYSTEM CONFIGURATION  
3.2. Components 

3.2.5. Industrial camera (USB camera) 

USB cameras can be used as industrial cameras. The following shows the industrial cameras that can be used. 

Interface standard Model Manufacturer Remarks 

USB3 Vision VTC-S016M00-TE ViSCO Technologies Corporation ・Imaging speed: 240 fps 

・Pixel: 1440 × 1080 VTC-S016C00-TE 

VTC-S023M00-TE ・Imaging speed: 165 fps 

・Pixel: 1920 × 1200 VTC-S023C00-TE 

 
■Optional parts for industrial cameras 

For industrial cameras with a C-mount lens mount standard, C-mount lenses can be attached as optical parts for 
condensing. Prepare them separately based on the cameras used. 
 

3.2.6. High-intensity lighting 

The following shows the high-intensity lighting that can be used. 

Model Manufacturer Remarks 

HB2-T5012W0-5F ViSCO Technologies Corporation Shape: Bar 

HB2-C22X1W0-IC Shape: Flat 
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3. SYSTEM CONFIGURATION  
3.2. Components 

3.2.7. Cable 

The following shows the required cables. 

 

No. Item Connector Description 

(1) Ethernet cable*1 RJ45 connector Used to connect the following devices and the switching HUB. 

・Target equipment (master station, servo amplifier, etc.) 

・Lighting controller 

・Personal computer 

(2) Lighting cable*2 SM3 connector Used to connect the lighting controller and the high-intensity 
lighting. 

(3) e-CON cable ・-*3 

・e-CON connector 

Used to connect the lighting controller and the USB cameras. 

(4) USB3.1 Gen1 cable ・Micro-B 

・Standard-A 

Used to connect the personal computer and the USB cameras. 

*1: For the standards of the Ethernet cables, refer to "(1) Ethernet cable". 

*2: For the lighting cable that can be used, refer to "(2) Lighting cable". 

*3: Use the connector supplied with the lighting controller. 
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3. SYSTEM CONFIGURATION  
3.2. Components 

(1) Ethernet cable 
Use Ethernet cables that satisfy the following specifications. 

Communication speed Type Standard 

1 Gbps Category 5e or higher, straight 
cable (shielded, STP) 

Cables that satisfy the following 
standards: 

・IEE802.3 (1000BASE-T) 

・ANSI/TIA/EIA-568-B (Category 5e) 

 
Cables for CC-Link IE TSN are available from Mitsubishi Electric System & Service Co., Ltd. (Catalogs for 
these cables are also available.) 
In addition, the connector processing of cable length is available for your preference. Please consult your local 
Mitsubishi representative. 

Communication 
speed 

Type Model Manufacturer 

1 Gbps Category 5e or higher, straight 
cable (double shielded, STP) 

SC-E5EW series Mitsubishi Electric System & 
Service Co., Ltd. 

 

(2) Lighting cable 
The following shows the lighting cables that can be used. 

Model Manufacturer Remarks 

VTLC-48RN-03F ViSCO Technologies Corporation 3 m extension cable 

VTLC-48RN-05F 5 m extension cable 

VTLA-48NW-E 2:1 branch cable 

 

3.2.8. Switching HUB and device stations 

Only the CC-Link IE TSN certification Class B products can be used as switching HUBs or device stations. 
For CC-Link IE TSN Class of each device, check the website of CC-Link Partner Association or the catalog or manual 
of each product. 
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3.3. Engineering Tool 
The following lists the engineering tools to be used in this solution. 

Engineering Tool Model Version 

MELSOFT VIMA SW1DNN-VIMA-M 1.000A or later 

GX Works3 SW1DND-GXW3-J 1.060N or later*1 

*1: Use version 1.125F or later when using the MELSEC MX Controller MX-R model. 

 

3.3.1. Operating environment 

The following table shows the operating environment for MELSOFT VIMA. 

Item Description 

Personal 
computer 

Main body Personal computer running Microsoft® Windows® 

OS*1 Windows® 11 (Home, Pro, Enterprise, Education, IoT Enterprise LTSC 2024) 

Processor Intel Core® i5 2.5 GHz or more 

Required 
memory 

Recommended: 32 GB or more 

Required: 16 GB or more 

Available storage space Recommended: SSD*2 400 GB or more 

Required: 40 GB or more 

Communication interface Data transfer rate 1 Gbps or more*3 

Display Resolution 1920 × 1080 pixels or more 

.NET Framework .NET Framework 4.6 or later 

*1: Operation is not guaranteed on operating systems other than those described above. 

*2: NVMe Gen4 or later SSD can be used. 

*3: When using a USB-to-LAN adapter, use a USB 3.0-compatible USB-to-LAN adapter. 
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3.4. Network Configuration 
This section shows the network topologies that are supported by MELSOFT VIMA and CC-Link IE TSN. 
Regardless of network configuration, only a single MELSOFT VIMA can be connected to the network. 

 

3.4.1. Line topology 

Only a single MELSOFT VIMA can be connected at the end of the network. 

 

No. 0: Master station 
No. 1, No. 2: Remote stations 
Class B: CC-Link IE TSN Class B devices 
(1) MELSOFT VIMA 
 

3.4.2. Star topology 

Only a single MELSOFT VIMA can be connected to an available port on the switching HUB. 

 
No. 0: Master station 
No. 1, No. 2: Remote stations 
Class B: CC-Link IE TSN Class B devices 
(1) Switching HUB (CC-Link IE TSN Class B-compatible) 
(2) MELSOFT VIMA 
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3.4.3. Mixture of the line topology and star topology 

Only a single MELSOFT VIMA can be connected at the end of the network. 

 

No. 0: Master station 
No. 1, No. 2, No. 4: Remote stations 
No. 3: Local station 
Class B: CC-Link IE TSN Class B devices 
(1) Switching HUB (CC-Link IE TSN Class B-compatible) 
(2) MELSOFT VIMA 
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3.5. Usage Precautions 
This section describes the precautions for using this solution. 
 

3.5.1. Ring topology 

This solution does not support ring topologies. When MELSOFT VIMA is connected to a ring topology system, TSN 
data cannot be collected. 
 

3.5.2. Ethernet adapter with multiple IP addresses assigned 

When multiple IP addresses are assigned to a single Ethernet adapter, the IP address with the smallest setting (value) 
is used by being compared with the IP addresses in the order of the first octet → second octet → third octet → fourth 
octet. 
Example: When "192.168.3.100" is added to the Ethernet adapter with "192.168.4.133" enabled, the IP address 
"192.168.3.100" is used. 
 

3.5.3. Connection to the switching HUB 

■Remote station with CC-Link IE TSN certification Class A 
Do not connect any remote station with CC-Link IE TSN certification Class A and this solution to the same switching 
HUB. Doing so may cause issues such as repeated disconnection and reconnection of the remote station with CC-
Link IE TSN certification Class A, which may affect the control of the remote station. 

■Ethernet devices 
Do not connect any Ethernet device to the switching HUB to which this solution is connected. Because cyclic data is 
sent to the connected Ethernet devices, communication may become unavailable depending on the Ethernet device. 
 

3.5.4. Use of USB-to-LAN adapter 

• When using a USB-to-LAN adapter, use a USB 3.1 Gen1 (USB 3.0)-compatible USB-to-LAN adapter. 

If a USB-to-LAN adapter that is not compatible with USB 3.1 Gen1 (USB 3.0) is used, this solution may not operate 
properly. 

• When connecting multiple USB devices to the personal computer using a USB hub, the personal computer may fail 

to import the data received with the USB-to-LAN adapter and the data may be lost. 

Whether data is being received correctly in the operating environment can be checked from the image information of 

the collected data and TSN control data information. If data is not received correctly, the message "This frame failed 

to receive images." or "This frame failed to receive TSN control data." is displayed for the corresponding frame. 

For details, refer to "Critical Moments Analytics Solution User's Manual". 
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3.5.5. Communication mode of the master station 

The master station supports only the multicast mode as its communication mode. 
Because MELSOFT VIMA is to be connected to the end of the network, if the communication mode of the master 
station is not the multicast mode, cyclic data cannot be transmitted to MELSOFT VIMA. 
For the setting procedure of the communication mode of the master station, refer to "4.10.1(1) Communication mode 
setting" and "4.10.2(1) Communication mode setting". 
 

3.5.6. Communication speed 

This solution supports only a configuration with a communication speed of 1 Gbps. Set the communication speed of 
each device to 1 Gbps. In addition, use devices that can communicate at 1 Gbps. 
For setting the communication speed of the master station, refer to the manual of each master station. 
 
 



Critical Moments Analytics Solution Introduction Guide 

 

 27 / 106  
BCN-89796-0228-A 

4. INTRODUCTION PROCEDURE 

4. INTRODUCTION PROCEDURE 
The following shows the procedure for introducing this solution (until data collection is executed). 
For the detailed introduction procedure and analysis of the collection data, refer to "Critical Moments Analytics Solution 
User's Manual". 

 

 
 

4.1 Preparation 

4.2 Installing MELSOFT VIMA 

4.3 License Registration 

4.4 Network Adapter Setting 

4.5 Wiring 

4.6 Creating a New Project 

4.7 Device Connection Setting 

4.8 Imaging Setting 

4.9 Application to Target Equipment 

4.10 Master Station Setting 

4.11 Final Adjustment of Imaging Environment 

4.12 TSN Control Data Collection Setting 

4.13 Execution of Data Collection 
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4.1. Preparation 
Before starting up Critical Moments Analytics Solution, prepare and set each device according to the system 
configuration. 
 

4.1.1. Preparing devices 

Prepare the devices required for starting up the solution and configuring settings according to the system configuration. 
For details of each device, refer to "3.2 Components". 

Device/software Description 

Lighting controller Used to control the camera imaging and lighting. 

Personal 
computer 

MELSOFT VIMA Used to set and operate this solution. 

Lighting (High-intensity lighting) Used as the lighting for the target equipment. 

Camera (USB camera) Used for imaging the target equipment. 

Lens Attach to the camera to be used. 

For instructions on how to attach, refer to the manuals of the camera and the 
lens to be used. 

Ethernet cable Used to connect the personal computer and lighting controller. 

USB3.1 Gen1 cable Used to connect the personal computer and the camera. 

e-CON cable Used to connect the lighting controller and the camera. 

Lighting cable Used to connect the lighting controller and the lighting. 
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4.1.2. USB camera driver setting 

To disable the energy-saving mode of the USB camera, change its driver settings. An example of the setting procedure 
is shown below. 

 
When the energy-saving mode of the USB camera is enabled, the camera automatically enters sleep mode if it 
is not operated for a certain period of time. When the camera enters sleep mode, the following symptoms may 
occur. 
• Disconnection between MELSOFT VIMA and the camera 
• Camera image stop 
• Imaging data missing 

 
 

1. Connect the USB camera to the USB 3.0 port on the personal computer. 

2. In Device Manager in Windows, right-click [Universal Serial Bus controllers] → [USB Root Hub (USB 3.0)] and 

select [Properties]. 
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3. Click the [Power Management] tab, and clear the check box for "Allow the computer to turn off this device to save 

power". 

 

4. Click the [OK] button. 
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4.1.3. Network setting for the personal computer 

Set the IP address and subnet mask for the network adapter that will be used by MELSOFT VIMA. An example of the 
setting procedure is shown below. 

 
For this solution, do not use a network adapter that is already used by other software. MELSOFT VIMA may not 
operate properly. 

 
 

1. In the Windows Control Panel, click [Network and Internet] → [Network and Sharing Center] → [Change adapter 

settings]. 

 

2. Right-click the network adapter to use, and then click [Properties]. 
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3. Select "Internet Protocol Version 4 (TCP/IPv4)", and then click [Properties]. 

 

4. Set the IP address and subnet mask according to the system, and then click the [OK] button. 

 

 

 
Set the IP address of the personal computer so that the first to third octets match those of the IP address of the 
device to be connected. Make sure to set an IP address that is different from other devices. 
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4.1.4. IP address setting of the lighting controller 

Set the IP address of the lighting controller. 
The first to third octets of the IP address of the lighting controller are set to "192.168.3" by default. The fourth octet can 
be set using the station number setting switch on the lighting controller. 
 

 
In GX Works3, the first to third octets of the IP address of the lighting controller change according to the first to 
third octets of the set IP address of the master station. In MELSOFT VIMA, change the IP address of the 
specifying lighting controller to be the same as the IP address setting of the master station. 

 
 

1. Rotate the station number setting switch on the lighting controller to set the station number (fourth octet of the IP 

address). 

Use x1 and x16 (hexadecimal numbers) for the setting. 
Example: To set the fourth octet to "30", set the station number setting switch as follows. 

 

 
Make sure to set a station number that is different from other devices. 
If the same station number is used on the same network, communication may fail because the device may 
communicate with an unintended device. 
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4.2. Installing MELSOFT VIMA 
The following shows the installation procedure for MELSOFT VIMA. 
Even after MELSOFT VIMA is installed by following this procedure, it cannot be used until the license registration is 
complete. After the installation, obtain and register the license by following the procedure in "4.3 License Registration". 

 
To obtain a license for MELSOFT VIMA, the hardware code that is registered after the installation is required. 
Thus, MELSOFT VIMA must be installed before obtaining the license. 

 
 

1. Double-click "setup.exe" in the installer folder*1 for MELSOFT VIMA. 
*1: If it is placed in a network drive, MELSOFT VIMA may not operate properly after the installation. 

2. When the redistribution package required for operating MELSOFT VIMA is not installed, the following window 
appears. Click the [Install] button. 

 

3. When the setup window appears, click the [Next] button. 
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4. Select the installation destination, and then click the [Next] button. 

 

5. Check the license agreement, and then select "I accept the terms of the license agreement". 

6. Click the [Install] button. 
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7. The following window appears when the installation is complete. 
Select whether to restart the personal computer, and then click the [Finish] button. 

 

8. When "Yes, I want to restart my computer now." is selected in Step 7, the personal computer automatically restarts. 
When "No, I will restart my computer later." is selected, restart the personal computer. 
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4.3. License Registration 
To use MELSOFT VIMA, obtain and register the license file. 
 

4.3.1. Obtaining the license file 

Acquire the license file of MELSOFT VIMA from "MELSOFT VIMA License Request From" in the MITSUBISHI 
ELECTRIC Factory Automation website. (A hardware code is required for the application.) 
After the application, the license key file (vima_license_[16 characters of hardware code].lic) will be sent as an e-mail 
attachment. 
The following shows the detailed acquisition procedure. 
 

1. Start MELSOFT VIMA. 

2. On the top screen, click "Configure the environment setting." → "License management". 

 

3. Copy "Hardware code" under "Device specific information". 
Clicking the [Copy] button copies the code. 
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4. Submit the hardware code to "MELSOFT VIMA License Request From" in the MITSUBISHI ELECTRIC Factory 
Automation website to request the license issuance. 

 
• The hardware code required for the license issuance is a unique ID. It is set for each device (personal 

computer) and cannot be used for other devices (personal computers). 
• The license file is sent to the entered e-mail address. Be careful not to enter an incorrect e-mail address. 
• Do not change the name and extension (.lic) of the license file. 

 
 

4.3.2. License file registration 

Register the acquired license file in MELSOFT VIMA. 
 

1. Start MELSOFT VIMA. 

2. On the top screen, click "Configure the environment setting." → "License management". 
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3. Click the [License registration] button. 

 

4. Select the license file acquired in "4.3.1 Obtaining the license file", and click the [Open] button. 

 
 

When the license registration is complete, "Status" under "License registration status" becomes "Registered". 

 



Critical Moments Analytics Solution Introduction Guide 

 

 40 / 106  
BCN-89796-0228-A 

4. INTRODUCTION PROCEDURE  
4.4. Network Adapter Setting 

4.4. Network Adapter Setting 
The following shows the procedure for setting the network adapter to be used in MELSOFT VIMA. 
 

1. On the top screen of MELSOFT VIMA, click "Configure the environment setting" → "Network adapter setting". 

 

2. Select the network adapter to be used in "Network adapter" under "Network adapter selection". 

 
 
  



Critical Moments Analytics Solution Introduction Guide 

 

 41 / 106  
BCN-89796-0228-A 

4. INTRODUCTION PROCEDURE  
4.4. Network Adapter Setting 

3. Click the [Apply] button. 

 
When the setting is successfully applied, the message "The setting has been applied." appears. 

 

 
When "<Not use>" is selected in Step 2, the network adapter setting of MELSOFT VIMA is disabled. 
To use the network adapter currently used in MELSOFT VIMA in another software, disable the network adapter 
setting. 
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4.5. Wiring 
Connect each device. 
 

4.5.1. Wiring MELSOFT VIMA and each device 

Connect MELSOFT VIMA to each device prepared in "4.1.1 Preparing devices". The following shows the connection 
example. 

 

No. Device/software Description 

(1) 

Lighting controller ・Connect to the personal computer with an Ethernet cable. 

・Connect to the high-intensity lighting with lighting cables. 

・Connect to the USB cameras with e-CON cables. 

(2) 
Personal 
computer 

MELSOFT VIMA ・Connect to the lighting controller with an Ethernet cable. 

・Connect to the USB cameras with USB 3.1 Gen1 cables. 

(3) High-intensity lighting Connect to the lighting controller with lighting cables. 

(4) 
Camera (with lens attached) ・Connect to the personal computer with USB 3.1 Gen1 cables. 

・Connect to the lighting controller with e-CON cables. 

 
Always power off the devices before connecting/disconnecting cables and performing wiring. Failure to do so 
may cause circuit damage, fire, or electric shock. 
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4.5.2. Wiring for lighting controller control port 

Connect an industrial camera or high-intensity lighting to each control port of the lighting controller. The following shows 
the wiring example. 

 

When connecting the cameras and lighting to the control ports of the lighting controller, wire them according to the 
following conditions. 
For details, refer to "Flash Light Controller MVTFC1-0448-00 Hardware Guide". 
• Allocate one or more units of lighting to a single camera. (When connecting a single camera to a single lighting 

controller, up to four*1 units of lighting can be allocated.) 
• When connecting a set of a single camera and a single unit of lighting to the lighting controller, wire the camera and 

the lighting respectively to the imaging control port and lighting control port of the same CH. 
*1: When a branch cable is used, two units of lighting can be connected to a lighting control port of 1 CH, thus up to 

eight units of lighting can be allocated. 
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4.6. Creating a New Project 
Create a new MELSOFT VIMA project. 
 

1. Turn on the power of each device. 

 
Do not touch the camera or lighting while the power is ON or immediately after it has been turned off as they 
become very hot. There is a risk of burns. When using the device in an enclosed space, cool it using a fan or air. 

 

2. Start MELSOFT VIMA. 

3. On the top screen, click "Start collection and analysis" → "Create new project". 

 

A new project will be created. 
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4.7. Device Connection Setting 
Connect MELSOFT VIMA to the lighting controller and cameras. In addition, set the control port of the lighting 
controller. 
 

1. In "Lighting controller IP address" under "Lighting controller" in the device connection screen, enter the IP address 

of the lighting controller. 

 

 
The first to third octets of the IP address of the lighting controller are set to "192.168.3" by default. 
Set the fourth octet to the same value as the station number set in "4.1.4 IP address setting of the lighting 
controller". 

 

2. Click the [Connection] button to turn it on. 

 

 
If the camera to be used is not displayed in "Camera list" at this point, click the [Update the camera connection 
status] button to update the camera connection status. 
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3. Click the [Imaging control port automatic configuration] button in the "Imaging control port" section under "Control 

port". 

 

4. When the following dialog box appears, click the [OK] button. 

 

5. When the automatic configuration is complete, the following dialog box appears. Click the [OK] button. 

 
Each control port is automatically set based on the connection status of the imaging control ports of the lighting 
controller. 

 

 
 

• When there is a camera or lighting that is not to be used in this solution, manually change the assignment 
setting to "Unassigned". 

• To assign multiple units of lighting to a single camera, manually change the assignment of lighting. 
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4.8. Imaging Setting 
Adjust the imaging environment by setting the parameters for the lighting controller, cameras, and lighting. 
 

4.8.1. Setting the frame rate 

Configure settings for performing imaging of each camera without the master station. 
 

1. Click the [Imaging setting] button. The imaging setting function is displayed. 

 

2. Set "Common setting" of the [Camera setting] window as follows. 

 

Item Description 

Imaging setting based on 
the TSN control cycle 

Perform imaging based on 
the control cycle 

Set to off. 

Frame rate setting Frame rate [fps] Set a value assuming operation of this solution 
(when performing imaging synchronously with the 
TSN control data of the target equipment). 

 
 

 
The value displayed in "Configurable frame rate" indicates the maximum frame rate that can currently be set. 
If the "Configurable frame rate" is lower than the desired frame rate, adjusting the resolution using the 
procedure described in "4.8.2(1) Adjusting the resolution" can increase the "Configurable frame rate". 
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4.8.2. Adjusting the camera and lighting 

Start imaging on each camera in the live view, and adjust the parameters according to the imaging condition. 

 
When a camera starts imaging, the lighting turns on or flashes. 
The high-intensity lighting to be used in this solution emits highly intense strobe light. Do not look directly at the 
light emitting part. Doing so may cause corneal or retinal damage due to the strong radiation. 
Use a dimming/shielding plate or similar so that light does not get in your eyes when using the lighting. 

 
 

1. From the [Camera list] window, select the camera to start capturing images in the live view. 

 

2. Click the [Imaging start/stop] button to turn it on. 

Imaging is started and the camera image is displayed. 
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(1) Adjusting the resolution 
To change the frame rate relative to the speed of the imaging target (to increase "Configurable frame rate") or 
to change the resolution of the camera image, adjust the resolution of the camera image. 
 
1. Click the [Imaging start/stop] button of the adjustment target camera to turn it off. 

 

2. Adjust "Resolution adjustment" according to the imaging condition in the "Resolution setting" section under 
any of "Control port CAM1 setting" to "Control port CAM4 setting"*1 in the [Camera setting] window. 
*1: The setting is displayed according to the camera selected in Step 1. 

 

Item Description 

Resolution adjustment Adjust the level of the resolution (width × height). (The imaging size 
will be adjusted based on the center of the camera image.) 

To increase "Configurable frame rate", lower the level of resolution. 

Parameter details Click the [ ] button to display. 

 Width Adjust the width of the camera image. 

Height Adjust the height of the camera image. 

Offset Horizontal direction Adjust the offset in the horizontal direction. 

Offset Vertical direction Adjust the offset in the vertical direction. 
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For "Maximum frame rate supported with the current resolution setting", the maximum frame rate that 
can be used with the corresponding camera is displayed. 
When multiple cameras are connected, "Configurable frame rate" in the frame rate setting section 
shows the lowest "Maximum frame rate supported with the current resolution setting" among all 
cameras. 
To increase "Configurable frame rate", adjust the resolutions of all cameras. 

 
 

3. Click the [Imaging start/stop] button to turn it on. The camera image changes to the set resolution. 

 

 

(2) Adjusting the brightness 
When the camera image is dark or too bright, adjust the brightness of the camera and lighting. 
 
1. Click the [Imaging start/stop] button of the adjustment target camera to turn it on. 
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2. While checking the camera image, adjust "Exposure adjustment" under any of "Control port CAM1 setting" 
to "Control port CAM4 setting"*1 in the [Camera setting] window. 
*1: The setting is displayed according to the camera selected in Step 1. 

 

Item Description 

Brightness adjustment Adjust it to achieve adequate brightness. (Move the slider so that 
the value gradually become larger from the lower limit value.) 

Parameter details Click the [ ] button to display. 

 Exposure time [μs] Adjust the brightness of the camera. 

Lighting ON time [μs] Adjust the time during which the lighting is ON. 

 
 

• When the desired brightness cannot be achieved with the exposure adjustment (when the camera 
image is still dark), the methods listed below can brighten the camera image. Perform them as 
necessary. 

Item Notes 

Increasing the aperture with 
the aperture ring on the lens 
(lower the f-number) 

Note that increasing the aperture of the lens makes the depth of 
field (the range that appears to be focused) shallower. 

Adjusting the camera position 
and direction of the lighting 

The cameras and lighting become very hot while the power is 
ON. Be careful of burns while adjusting them. 

Increasing the number of 
lighting units 

When increasing the number of lighting units, you will need to 
perform wiring and configure settings again. 

Perform all the procedures from "4.5 Wiring" to this setting again. 

• When the camera image is blurry, shortening the exposure time can decrease the motion blur of 
the image. 
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(3) Adjusting the focus and field of vision 
When the angle of view of the camera image is misaligned or the camera image is out of focus, adjust the field 
of view and the focus of the camera. 
 
1. Adjust the placement of the target camera according to the desired field of view. 

• When the field of view is narrow: Increase the working distance. (When increasing the working distance 
is impossible, change the lens to one with a shorter focal length.) 

• When the field of view is wide: Reduce the working distance. Or, change the lens to one with a longer 
focal length. 

2. Rotate the focus ring on the lens of the target camera to adjust the focus. 

 
The cameras become very hot while the power is ON. Be careful of burns while adjusting them. 

 
 

(4) Adjusting the white balance 
If there is a problem with the color tone of the camera image when a color camera is used, adjust the white 
balance of the camera image. 
 
1. Click the [Imaging start/stop] button of the adjustment target camera to turn it on. 
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2. "Control port CAM1 setting" to "Control port CAM4 setting"*1 in the [Camera setting] window → Click the 
[Execute] button for "Automatic white balance adjustment". 
The white balance is automatically adjusted. 
*1: The setting is displayed according to the camera selected in Step 1. 

 

3. To perform more detailed white balance adjustment, click the [ ] button of the "Parameter details" section, 
and adjust the following items. 

 

Item Description 

White balance Red Adjust the red tone (R gain). 

White balance Blue Adjust the blue tone (B gain). 
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4.8.3. Saving the project 

When the adjustments of the camera image are completed, save the settings as a project. 
 

1. Start imaging on each camera and check the imaging status. 
If there is an issue, adjust the cameras and lighting again. 

 

2. In the menu, click [File] → [Save project]. 

 

3. Set the desired save destination and file name and click the [Save] button. 

 
The project file (.vmcp) will be saved. 
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4.9. Application to Target Equipment 
Apply this solution to the imaging target equipment. 
 

4.9.1. Preparing devices 

Prepare the devices and software required for connecting the imaging target equipment to this solution. 
For details of each device, refer to "3.2 Components". 

Device/software/file Description 

Motion module or MELSEC MX 
Controller 

The MELSEC iQ-R series Motion module or MELSEC MX Controller MX-R 
model which controls the imaging target in existing equipment. 

It is used as the master station for imaging control in this solution. 

Switching HUB*1 Used to connect the devices in the existing equipment and devices in this 
solution. 

Personal 
computer*2 

GX Works3*3 Used to configure the settings of the master station and create the imaging 
control program. 

Lighting controller profile Used to configure the settings of the lighting controller in GX Works3. 

Ethernet cable Used to connect the devices in the existing equipment and devices in this 
solution. 

USB cable Used to write the settings and programs to the master station in GX Works3. 

*1: This is not required when the devices in the existing equipment and devices in this solution are connected in the 

line topology. 

*2: The same personal computer as the one that uses MELSOFT VIMA can be used. 

*3: Version 1.123D is used in this guide. 

 

(1) Profile for the lighting controller 
In this solution, a profile is used to use the lighting controller in the CC-Link IE TSN configuration setting. 
Download the profile for the lighting controller from the MITSUBISHI ELECTRIC Factory Automation website. 
www.MitsubishiElectric.co.jp/fa 
A profile is a setting file that stores the information required for the startup, operation, and maintenance of 
devices compatible with the CC-Link family. Registering the profile to the engineering tool for the master 
station adds "LED Lighting Controller" to the "Module List" in the CC-Link IE TSN configuration window. 
For the procedure for registering the profile, refer to "GX Works3 Operating Manual". 
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4.9.2. Connecting target equipment and solution 

Wire the devices in the target equipment and devices in this solution with Ethernet cables, and then connect them to 
the CC-Link IE TSN network. 
The following shows the wiring example when adopting the star topology. 
For details and precautions for the network configuration, refer to "3.4 Network Configuration". 
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4.10. Master Station Setting 
On GX Works3, configure the settings and create the program for the operation of solution on the master station. 
Configure the settings and create the program according to the master station model to be used. 
 

4.10.1. When using a Motion module 

This section describes the setting procedure when a MELSEC iQ-R series Motion module is used as the master 
station. 
In this section, the lighting controller is set to station number 1 as an example. In addition, "n" in the remote devices 
shown in this section is a value determined by the station number setting. 
 

(1) Communication mode setting 
Set the communication mode of the Motion module to be a master station. 
For this solution, change the communication mode of the Motion module to "Multicast Mode" to obtain the 
cyclic data with MELSOFT VIMA. 
 
1. Start GX Works3. 
2. Click [Project] → [Open] in the menu. 

 
3. Select the project used for controlling the imaging target equipment, and then click the [Open] button. 
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4. In the Navigation window, double-click [Parameter] → [Module Information] → [(Model name of the Motion 
module)] → [Module Parameter (Network)]. 

 

5. Click [Application Settings] in the setting item list, and then set [Communication Mode] under 
[Communication Mode] in the setting items to "Multicast". 

 

 
The cyclic transmission time (communication cycle interval) when the communication mode is 
"Multicast" is longer than that of when the communication mode is "Unicast". 
For guidelines of the communication cycle interval, refer to the manual of each Motion module. 
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(2) Network configuration setting (adding the lighting controller) 
Add the lighting controller to the network configuration of the existing equipment. 
In addition, configure the network synchronous communication setting to synchronize the control timing of the 
motion device and the lighting controller. 
If the profile for the lighting controller is not registered, register it beforehand. 
 
1. Click [Basic Settings] in the setting item list, and then double-click "<Detailed Setting>" of [Network 

Configuration Settings] under [Network Configuration Settings] in the setting item. 

 

The CC-Link IE TSN configuration window appears. 
2. In the module list, select [CC-Link IE TSN Module (ViSCO Technologies Corporation)] → [LED Lighting 

Controller] → [MVTFC1-0448-00], and then drag and drop it to the station list or the network configuration 
diagram. 
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3. Set "Network Synchronous Communication" of the added lighting controller to "Synchronous". 

 

 
If there are any devices to synchronize with the lighting controller other than the Motion module, set 
"Network Synchronous Communication" of the devices to "Synchronous". 

 
 

4. Set the start number, IP address, or other items of the link devices (RX, RY, RWr, RWw) according to the 
system. 

 
 

 
• Set the IP address of the lighting controller to the same value as the one specified in "4.7 Device 

Connection Setting". 
• If the start number setting for link devices is not displayed, click the [Detailed Display] button to 

display it. 
 

 
Make sure that the "Motion Control Station" check box of the lighting controller is selected. (It is 
selected by default.) 

 
 

5. Click the [Close with Reflecting the Setting] button. 
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6. Click the [Apply] button. 

 

 
If a switching HUB is added to the system configuration when this solution is introduced, set [TSN HUB 
Setting] displayed by selecting [Basic Settings] → [Connection Device Information] to "Use TSN HUB" 
before performing Step 6. 
For details, refer to the manual of each Motion module. 

 
 

(3) Network I/O setting 
To create a program for controlling the CH□ imaging control signals (RYn0 to RYn3), label each remote device 
of the lighting controller. 
 
1. In the Navigation window, double-click [Parameter] → [Module Information] → [(Model name of the Motion 

module)] → [Module Extended Parameter]. 
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The motion control setting function is displayed. 

 

2. In the Navigation widow of the motion control setting function, double-click [Network I/O]. 

 
3. Select the labeling target check boxes of the following data types of the lighting controller "MVTFC1-0448-

00". 
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Data type Description Created label*1 

RYn0 CH1 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH1 

RYn1 CH2 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH2 

RYn2 CH3 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH3 

RYn3 CH4 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH4 

RWrn0 Module status area MVTFC1_0448_00_001_Module_Status_Area 

RWrn1 Error code MVTFC1_0448_00_001_Error_Code 

*1: The names of the created labels differ depending on the setting. The names listed in this table are 
examples of the default setting. 

 
 

In the example shown in this guide, the following remote devices are labeled: RYn0 to RYn3 and 
RWrn0 which are required for creating the imaging control program and RWrn1 which indicates the 
error code of the lighting controller. 
For details on each remote device of the lighting controller, refer to the manual of the lighting controller. 

 

 
4. Click the [Create Label] button. 

 

5. Click the [Yes] button. 

 
The global labels of the remote devices selected in Step 3 are created in [Label] → [Global Label] → 
[NW+Global1] in the Navigation window. 
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(4) Creating the imaging control program 
Create the imaging control program for controlling the CH□ imaging control signals (RYn0 to RYn3). 

 
Write the code of the imaging control program in the motion control program or the sequence program. 
The imaging control program must be executed according to the communication cycle interval of the 
Motion module. Therefore, write the code in a program which can be executed at the communication 
cycle interval of the Motion module. 
The minimum setting values for the execution cycle of each program are as follows. 
• Motion control program: 62.5 [μs] 
• Sequence program: 500.0 [μs] 

 
 

(a) When creating code with the motion control program 
The following describes the procedure for writing code of the imaging control program in the motion 
control program. 
 
■Setting the fixed scan interval 

Code of the imaging control program must be written in a periodic execution type program. The 
execution cycle of the program must match the communication cycle interval of the Motion module. 
The following describes the procedure for setting the fixed scan interval of the periodic execution 
type program. 

 
If the corresponding periodic execution type program does not exist in the existing project, 
create a new periodic execution type program. For creating a new periodic execution type 
program, refer to "GX Works3 Operating Manual". 

 
 

1. In the Navigation window of the motion control setting function, double-click [Basic Setting]. 
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2. Double-click "<Detailed Setting>" of [Program Execution Setting] under [Program Execution 
Setting]. 

 

3. Double-click "Fixed Scan Interval Setting" of the program to be used for the imaging control. 

 

4. Set the fixed scan interval to the same value as the communication cycle interval of the Motion 
module, and then click the [OK] button. 
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The communication cycle interval of the Motion module can be checked by following the 
steps below. 
1. In the Navigation window of GX Works3, double-click [Parameter] → [Module 

Information] → [(Model name of the Motion module)] → [Module Parameter (Network)]. 
2. Check the communication cycle interval set in [Communication Period Interval Setting 

(Do not Set it in Units of 1us)] or [Communication Period Interval Setting (Set it in Units 
of 1us)] under [Basic Period Setting] displayed by selecting [Basic Settings] → 
[Communication Period Setting]. 

 
 

5. Click the [Apply] button. 

 

 
■Writing code of the imaging control program 
1. In the Navigation window of the motion control setting function, double-click [Label] → [Global 

Label] → [Global]. 
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2. Create the following global label to be used as the trigger of the imaging control. 
• Label name: bImageCaptureTrig 
• Data type: Bit (0..3) 
• Class: VAR_GLOBAL 

 

3. Open the program to be used from [Program] → [Fixed Scan] in the Navigation window, and then 
write the following code. 

 

No. Process description 

(1) Turn on the imaging control signal trigger "bImageCaptureTrig" to perform imaging. 

Write the desired timing. 

(2) When the trigger Ready (b1) of the module status area (RWrn0) of the lighting 
controller is ON, set the imaging control signal trigger "bImageCaptureTrig" for the 
CH□ imaging control signals (RYn0 to RYn3). 

(3) When the trigger Ready (b1) of the module condition area (RWrn0) of the lighting 
controller is OFF, turn off the CH□ imaging control signals (RYn0 to RYn3). 

 
Interruptions must be enabled by the EI instruction to execute the imaging control program 
in a periodic execution type program. Add the process to execute the EI instruction to a 
program other than the imaging control program. 

 

 
4. In the menu of the motion control setting function, click [Convert] → [Rebuild All]. 

 

(1) 

(2) 

(3) 
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5. Click the [OK] button. 
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(b) When creating code with the motion control program 
The following describes the procedure for writing code of the imaging control program in the 
sequence program. 
 
■Public label setting 

When writing code of the imaging control program in the sequence program, make the labels of the 
lighting controller created in "4.10.1(3) Network I/O setting" public to the CPU module side. 
 

1. In the Navigation window of the motion control setting function, double-click [Label] → [Global 
Label] → [NW+Global1]. 

 

2. Set the public label column for the global labels of the lighting controller to "Enabled". 

 
3. Click [Convert] → [Rebuild All] in the menu. 
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4. Click the [OK] button. 

 
5. Click [Convert] → [Reflect Public Labels] in the menu. 

 

6. Click the [Yes] button. 

 
7. Click the [OK] button. 
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■Setting the fixed scan interval 
Code of the imaging control program must be written in a periodic execution type program. The 
execution cycle of the program must match the communication cycle interval of the Motion module. 
The following describes the procedure for setting the fixed scan interval of the periodic execution 
type program. 

 
If the corresponding periodic execution type program does not exist in the existing project, 
create a new periodic execution type program. For creating a new periodic execution type 
program, refer to "GX Works3 Operating Manual". 

 
 

1. In the Navigation window of GX Works3, double-click [Parameter] → [(CPU module name)] → 
[CPU Parameter]. 

 
2. Click [Program Setting] in the setting item list, and then double-click "<Detailed Setting>" of 

[Program Setting] under [Program Setting] in the setting item. 
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3. Double-click "Detailed Setting Information" of the program to be used for the imaging control. 

 
4. Set the fixed scan interval to the same value as the communication cycle interval of the Motion 

module, and then click the [OK] button. 

 
 

 
The communication cycle interval of the Motion module can be checked by following the 
steps below. 
1. In the Navigation window of GX Works3, double-click [Parameter] → [Module 

Information] → [(Model name of the Motion module)] → [Module Parameter (Network)]. 
2. Check the communication cycle interval set in [Communication Period Interval Setting 

(Do not Set it in Units of 1us)] or [Communication Period Interval Setting (Set it in Units 
of 1us)] under [Basic Period Setting] displayed by selecting [Basic Settings] → 
[Communication Period Setting]. 
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5. Click the [Apply] button. 

 
 

■Writing code of the imaging control program 
1. In the Navigation window of GX Works3, double-click [Label] → [Global Label] → [Global]. 

 

2. Create the following global label to be used as the trigger of the imaging control. 
• Label name: bImageCaptureTrig 
• Data type: Bit (0..3) 
• Class: VAR_GLOBAL 
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3. Open the program to be used from [Program] → [Fixed Scan] in the Navigation window, and then 
write the following code. 

 

No. Process description 

(1) Turn on the imaging control signal trigger "bImageCaptureTrig" to perform imaging. 

Write the desired timing. 

(2) When the trigger Ready (b1) of the module status area (RWrn0) of the lighting controller 
is ON, set the imaging control signal trigger "bImageCaptureTrig" for the CH□ imaging 
control signals (RYn0 to RYn3). 

(3) When the trigger Ready (b1) of the module condition area (RWrn0) of the lighting 
controller is OFF, turn off the CH□ imaging control signals (RYn0 to RYn3). 

 
Interruptions must be enabled by the EI instruction to execute the imaging control program 
in a periodic execution type program. Add the process to execute the EI instruction to a 
program other than the imaging control program. 

 
 

 

  

(1) 

(2) 

(3) 
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(5) Writing to the programmable controller 
Write the configured settings to the programmable controller. 
 
1. Connect the CPU module to GX Works3 with a USB cable. 

 
2. In the menu of GX Works3, click [Convert] → [Rebuild All]. 

 
3. Click the [OK] button. All the programs will be rebuilt. 

 
4. Click [Online] → [Write to PLC] in the menu. 
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5. Click the [Parameter + Program] button, and then click the [Execute] button. 

 
The data will be written. 

6. After the data is written, reset the CPU module and change the status from STOP to RUN. 
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4.10.2. When using a MELSEC MX Controller 

This section describes the setting procedure when a MELSEC MX Controller MX-R model is used as the master 
station. 
In this section, the lighting controller is set to station number 1 as an example. In addition, "n" in the remote devices 
shown in this section is a value determined by the station number setting. 
 

(1) Communication mode setting 
Set the communication mode of the MELSEC MX Controller. 
For this solution, change the communication mode of the MELSEC MX Controller to "Multicast Mode" to obtain 
the cyclic data with MELSOFT VIMA. 
 
1. Start GX Works3. 
2. Click [Project] → [Open] in the menu. 

 
3. Select the project used for controlling the imaging target equipment, and then click the [Open] button. 
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4. In the Navigation window, double-click [Parameter] → [(Model name of the MELSEC MX Controller)] → 
[Module Parameter (Port 1/2: CC-Link IE TSN)] → [Module Parameter (CC-Link IE TSN)]. 

 
5. Click [Application Settings] in the setting item list, and then set [Communication Mode] under 

[Communication Mode] in the setting items to "Multicast". 

 

 
The cyclic transmission time (communication cycle interval) when the communication mode is 
"Multicast" is longer than that of when the communication mode is "Unicast". 
For guidelines of the communication cycle interval, refer to the manual of each MELSEC MX 
Controller. 
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(2) Network configuration setting (adding the lighting controller) 
Add the lighting controller to the network configuration of the existing equipment. 
In addition, configure the network synchronous communication setting to synchronize the control timing of the 
motion device and the lighting controller. 
If the profile for the lighting controller is not registered, register it beforehand. 
 
1. Click [Basic Settings] in the setting item list, and then double-click "<Detailed Setting>" of [Network 

Configuration Settings] under [Network Configuration Settings (CC-Link IE TSN Configuration)] in the 
setting item. 

 
The CC-Link IE TSN configuration window appears. 

2. In the module list, select [CC-Link IE TSN Module (ViSCO Technologies Corporation)] → [LED Lighting 
Controller] → [MVTFC1-0448-00], and then drag and drop it to the station list or the network configuration 
diagram. 

 

3. Set "Network Synchronous Communication" of the added lighting controller to "Synchronous". 

 



Critical Moments Analytics Solution Introduction Guide 

 

 80 / 106  
BCN-89796-0228-A 

4. INTRODUCTION PROCEDURE  
4.10. Master Station Setting 

 
If there are any devices to synchronize with the lighting controller other than the MELSEC MX 
Controller, set "Network Synchronous Communication" of the devices to "Synchronous". 

 
 

4. Set the start number, IP address, or other items of the link devices (RX, RY, RWr, RWw) according to the 
system. 

 
 

 
• Set the IP address of the lighting controller to the same value as the one specified in "4.7 Device 

Connection Setting". 
• If the start number setting for link devices is not displayed, click the [Detailed Display] button to 

display it. 
 

 
Make sure that the "Network Label" check box of the lighting controller is selected. (It is selected by 
default.) 

 
 

5. Click the [Close with Reflecting the Setting] button. 

 

6. Click the [Apply] button. 
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If a switching HUB is added to the system configuration when this solution is introduced, set [TSN HUB 
Setting] displayed by selecting [Basic Settings] → [Connection Device Information] to "Use TSN HUB" 
before performing Step 6. 
For details, refer to the manual of each MELSEC MX Controller. 

 
 

(3) Network label setting 
To create a program for controlling the CH□ imaging control signals (RYn0 to RYn3), label each remote device 
of the lighting controller. 
 
1. In the Navigation window, double-click [Parameter] → [(Model name of the MELSEC MX Controller)] → 

[Module Parameter (Port 1/2: CC-Link IE TSN)] → [Network Label Setting]. 

 
2. Select the labeling target check boxes of the following data types of the lighting controller "MVTFC1-0448-

00". 

 

Data type Description Created label*1 

RYn0 CH1 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH1 

RYn1 CH2 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH2 

RYn2 CH3 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH3 
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Data type Description Created label*1 

RYn3 CH4 imaging control signal MVTFC1_0448_00_001_Imaging_Control_Signal_CH4 

RWrn0 Module status area MVTFC1_0448_00_001_Module_Status_Area 

RWrn1 Error code MVTFC1_0448_00_001_Error_Code 

*1: The names of the created labels differ depending on the setting. The names listed in this table are 
examples of the default setting. 

 
 

In the example shown in this guide, the following remote devices are labeled: RYn0 to RYn3 and 
RWrn0 which are required for creating the imaging control program and RWrn1 which indicates the 
error code of the lighting controller. 
For details on each remote device of the lighting controller, refer to the manual of the lighting controller. 

 
 

3. Click the [Create Label] button. 

 

4. Click the [Yes] button. 

 
The global labels of the remote devices selected in Step 2 are created in [Label] → [Global Label] → 
[NW+Global1] in the Navigation window. 

 
  



Critical Moments Analytics Solution Introduction Guide 

 

 83 / 106  
BCN-89796-0228-A 

4. INTRODUCTION PROCEDURE  
4.10. Master Station Setting 

(4) Creating the imaging control program 
Create the imaging control program for controlling the CH□ imaging control signals (RYn0 to RYn3). 
 
■Setting the fixed scan interval 

Code of the imaging control program must be written in a periodic execution type program. The execution 
cycle of the program must match the communication cycle interval of the MELSEC MX Controller. 
The following describes the procedure for setting the fixed scan interval of the periodic execution type 
program. 

 
If the corresponding periodic execution type program does not exist in the existing project, create a 
new periodic execution type program. For creating a new periodic execution type program, refer to "GX 
Works3 Operating Manual". 

 
 

1. In the Navigation window, double-click [Parameter] → [(Model name of the MELSEC MX Controller)] → 
[CPU Parameter]. 

 
2. Click [Program Setting] in the setting item list, and then double-click "<Detailed Setting>" of [Program 

Setting] under [Program Setting] in the setting item. 
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3. Double-click "Detailed Setting Information" of the program to be used for the imaging control. 

 
4. Set the "Specified Time Intervals" to the same value as the communication cycle interval of the MELSEC 

MX Controller, and then click the [OK] button. 

 

 
 

The communication cycle interval of the MELSEC MX Controller can be checked by following the steps 
below. 
1. In the Navigation window, double-click [Parameter] → [(Model name of the MELSEC MX 

Controller)] → [Module Parameter (Port 1/2: CC-Link IE TSN)] → [Module Parameter (CC-Link IE 
TSN)]. 

2. Check the communication cycle interval set in [Communication Period Interval Setting (Do not Set 
it in Units of 1us)] or [Communication Period Interval Setting (Set it in Units of 1us)] under [Basic 
Period Setting] displayed by selecting [Basic Settings] → [Communication Period Setting]. 
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5. Click the [Apply] button. 

 
 

■Writing code of the imaging control program 
1. In the Navigation window, double click [Label] → [Global Label] → [Global]. 

 

2. Create the following global label to be used as the trigger of the imaging control. 
• Label name: bImageCaptureTrig 
• Data type: Bit (0..3) 
• Class: VAR_GLOBAL 
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3. Open the program to be used from [Program] → [Fixed Scan] in the Navigation window, and then write the 
following code. 

 

No. Process description 

(1) Turn on the imaging control signal trigger "bImageCaptureTrig" to perform imaging. 

Write the desired timing. 

(2) When the trigger Ready (b1) of the module status area (RWrn0) of the lighting controller is ON, 
set the imaging control signal trigger "bImageCaptureTrig" for the CH□ imaging control signals 
(RYn0 to RYn3). 

(3) When the trigger Ready (b1) of the module condition area (RWrn0) of the lighting controller is 
OFF, turn off the CH□ imaging control signals (RYn0 to RYn3). 

 
Interruptions must be enabled by the EI instruction to execute the imaging control program in a periodic 
execution type program. Add the process to execute the EI instruction to a program other than the 
imaging control program. 

 
 

  

(1) 

(2) 

(3) 
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(5) Writing to the controller 
Write the configured settings to the controller. 
 
1. Connect the CPU module to GX Works3 with a USB cable. 

 
2. In the menu, click [Convert] → [Rebuild All]. 

 

3. Select "Create Execution Programs after Conversion", and then click the [OK] button. All the programs will 
be rebuilt. 
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4. Click [Online] → [Write to PLC] in the menu. 

 

5. Click the [Parameter + Program] button, and then click the [Execute] button. 

 
The data will be written. 

6. After the data is written, reset the CPU module and change the status from STOP to RUN. 
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4.11. Final Adjustment of Imaging Environment 
Perform the final adjustments of the imaging environment and check whether imaging can be performed at the desired 
timing and whether there are any issues with the image. 
 

4.11.1. Reading a project 

Start MELSOFT VIMA and open a saved project. 
 

1. Start MELSOFT VIMA. 

2. On the top screen, click "Start collection and analysis" → "Open project". 

 

3. Select a project file (.vmcp) and click the [Open] button. 
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4. When the following dialog box appears, click the [OK] button. 

 

The parameters will be written to the connected devices, and the project will open. 

 

 
If the device connection settings of the project and camera configuration (such as the types of cameras used or 
wiring) differ, the settings for each control port of the lighting controller will be lost and will not be written to the 
lighting controller. In this case, configure the control port settings again. 
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4.11.2. Setting the frame rate 

Configure settings for controlling imaging of each camera with the master station. 
 

1. Click the [Imaging setting] button. 

 

2. Set "Common setting" of the [Camera setting] window as follows. 

 
Item Description 

Imaging setting based on the 
TSN control cycle 

Perform imaging based on 
the control cycle 

Set to ON. 

Frame rate setting Imaging timing [Perform 
imaging once every n 
control cycles] 

Set the number of TSN control cycles for each 
imaging to the desired value. 

"Frame rate" is calculated based on this setting. 

 
If a state other than "Connected" is displayed in "TSN connection status", MELSOFT VIMA is not properly 
communicating with the devices via CC-Link IE TSN; as a result, imaging based on the control cycle cannot be 
started. 
For troubleshooting when a state other than "Connected" is displayed, refer to "Critical Moments Analytics 
Solution User's Manual". 
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The value displayed in "Configurable frame rate" indicates the maximum frame rate that can currently be set. 
If the "Configurable frame rate" is lower than the desired frame rate, adjusting the resolution using the 
procedure described in "4.8.2(1) Adjusting the resolution" can increase the "Configurable frame rate". 

 
 

4.11.3. Checking the camera images 

Start imaging for each camera and check the camera image during solution operation. 
 

1. Select the imaging target camera in the [Camera list] window or the live view area. 

 

2. When the imaging control signal triggers "bImageCaptureTrig[0] to [3]" for the target camera turn on, click the 

[Imaging start/stop] button to turn it on. 

Imaging starts. Check that there are no problems with the camera image. 
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• When the imaging control signal triggers "bImageCaptureTrig[0] to [3]" for the target camera turn off during 

imaging, an imaging error occurs, and update of the camera image stops. 
When the imaging control signal triggers "bImageCaptureTrig[0] to [3]" turn on again, imaging resumes. (The 
imaging error will be cleared.) 

• If there is a problem with the camera images, or if the control port settings could not be written to the lighting 
controller in "4.11.1 Reading a project", perform "4.8.2 Adjusting the camera and lighting" again. 

 
 

4.12. TSN Control Data Collection Setting 
In MELSOFT VIMA, configure the settings of the TSN control data to be collected. 
 

1. Click the [TSN control data] button. 

 

2. Set the following items according to the data to be collected. 

 

Item Description 

Device type Select the device type of the data to be collected. 

Device number Enter the device number (hexadecimal number) of the data to be collected. 

Data type Set the data type of the data to be collected. 

Comment Enter the comment for the data to be collected. (Optional) 

The set comments can be displayed in the graph legend. 
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4.13. Execution of Data Collection 
Perform data collection, and then check and save the collected data. 
 

4.13.1. Setting before starting data collection 

Before starting data collection, set the maximum collection time and the data to be displayed in the graph during 
collection. 
 

1. Click the [Data collection] button. 

 

2. In the [Collection buffer setting] window, check that the following items are "Connected". 

• "Camera imaging collection information" → "Camera list" → "Camera connection status" of all cameras 

• "TSN control data collection information" → "TSN connection status" 

 

 
If a state other than "Connected" is displayed, the correct buffer size will not be calculated and the collection will 
not be started. 
For troubleshooting when a state other than "Connected" is displayed, refer to "Critical Moments Analytics 
Solution User's Manual". 
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3. Set "Maximum collection time [s]" to the desired value. 

 

The value of "Required total buffer size" is updated according to the setting value. 
Compare "Required total buffer size" with the available memory size, and confirm that the data size is within the 
collectable range. 

 

4. To change the display format of the TSN control data and graph to be displayed during collection, click the [Graph 
display data setting] button. 
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5. The graph display data setting will be displayed. 
Set the display format or the TSN control data to be displayed according to your preferences, and then click the 
[OK] button. 
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4.13.2. Starting the data collection 

Start the data collection with the configured imaging environment and collection settings, and check the collected data. 
 

1. Select "Collection will stop when the buffer is full after collection begins." depending on the condition for stopping 

collection. 

 

Condition for stopping collection Description 

When automatically stopping the collection after the data for 
"Maximum number of frames"*1 is collected 

Select "Collection will stop when the 
buffer is full after collection begins.". 

When manually stopping the collection (The latest data for "Maximum 
number of frames"*1 at the time of stopping will be collected.) 

Deselect "Collection will stop when the 
buffer is full after collection begins.". 

*1: "Maximum number of frames" can be checked in the [Collection buffer setting] window. 

 

2. When the imaging control signal triggers "bImageCaptureTrig[0] to [3]" for the collection target turn on, click the 
[Stop collection] button. 

 
Collection starts, and the imaging data and the TSN control data currently being collected are displayed. 
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The display of the imaging data currently being collected can be switched using the following methods. 
• Clicking the [CAM1] button to [CAM4] button displays the corresponding imaging data. 
• Clicking the [4 in 1] button displays all imaging data. 

 

 
• To perform the collection, the imaging control signal triggers "bImageCaptureTrig[0] to [3]" for all the 

collection target cameras must be ON. 
• If the imaging control signal triggers "bImageCaptureTrig[0] to [3]" for the collection target turn off during 

collection, the collection fails. To restart the collection, confirm that the imaging control signal triggers 
"bImageCaptureTrig[0] to [3]" have turned on, and then click the [Start collection] button. 

• If the collection exceeding the available memory size is performed, data missing may occur or collection 
may fail. 

 
 

3. Depending on the selection status of "Collection will stop when the buffer is full after collection begins.", the 

collection will be stopped manually or automatically. 

• When "Collection will stop when the buffer is full after collection begins." is not selected 

Click the [Stop collection] button. The collection stops and the collected result preview appears. (The latest data 
for "Maximum number of frames" at the time of stopping will be collected.) 

 

• When "Collection will stop when the buffer is full after collection begins." is selected 

The collection automatically stops when the data for "Maximum number of frames" is collected, and the collected 
result preview appears. 

4. Check the collected results displayed in the collected result preview. 
When the desired data cannot be obtained, close the collected result preview and execute the collection again. 
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4.13.3. Saving of collection data 

Save the collected data as a collected file. 
 

1. Click the [Save the collection data.] button on the collected result preview. 

 

2. Set the desired save destination and file name and click the [Save] button. 

 

The collected file (.vmcd) will be saved. When the file has been saved, the message "The file has been saved." 
appears. 

 
If the size of the data to be saved is large, saving the data may take some time. Do not close MELSOFT VIMA 
while the data is being saved. 

 

3. After the saving processing is completed, close the collected result preview. 

4. In the menu, click [File] → [Close project] to close the project. 
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4.14. Post-Operation Procedure 
After completing the operation of the solution, follow the procedures below for the purpose of removing each device of 
the solution from the target equipment, deleting the settings, and others. 
 

(1) Removing each device of the solution from the target device 
Remove various devices such as the lighting controller and cameras, which were connected during 
introduction and operation of the solution, from the target equipment. 
 
 

(2) Setting the communication mode of the master station to unicast mode 
When the communication mode of the master station has been changed to the multicast mode, reset it to the 
unicast mode. 
 
■When the master station is a Motion module 

Change the communication mode of the Motion module set in "4.10.1(1) Communication mode setting" to 
the unicast mode. 
 

■When the master station is a MELSEC MX Controller 
Change the communication mode of the MELSEC MX Controller set in "4.10.2(1) Communication mode 
setting" to the unicast mode. 

 
 

(3) Deleting the lighting controller from the network configuration 
Delete the lighting controller added to the network configuration of the master station. 
 
■When the master station is a Motion module 

Delete the lighting controller added in "4.10.1(2) Network configuration setting (adding the lighting controller)" 
from the network configuration of the Motion module. 
 

■When the master station is a MELSEC MX Controller 
Delete the lighting controller added in "4.10.2(2) Network configuration setting (adding the lighting controller)" 
from the network configuration of the MELSEC MX Controller. 
 
 
  



Critical Moments Analytics Solution Introduction Guide 

 

 101 / 106  
BCN-89796-0228-A 

4. INTRODUCTION PROCEDURE  
4.14. Post-Operation Procedure 

(4) Deleting the global labels of the lighting controller 
Delete the global labels of the remote devices of the lighting controller. 
 
■When the master station is a Motion module 

Remove the remote devices of the lighting controller labeled in "4.10.1(3) Network I/O setting" from the 
labeling targets in the network label setting, and then perform the label creation again. 
The global labels of the remote devices of the lighting controller will be deleted. 

 
• If only the remote devices of the lighting controller are labeled in the network I/O setting, the label 

creation cannot be executed. Manually delete the global label list "NW+Global1". 
• When code of the imaging control program is written in the sequence program, apply the public 

labels again after deleting the global labels of the remote devices of the lighting controller. 
 

 
■When the master station is a MELSEC MX Controller 

Remove the remote devices of the lighting controller labeled in "4.10.2(3) Network label setting" from the 
labeling targets in the network label setting, and then perform the label creation again. 
The global labels of the remote devices of the lighting controller will be deleted. 
 
 

(5) Deleting the imaging control program 
Delete the imaging control program written in the master station. 
 
■When the master station is a Motion module 

Delete the imaging control program written in "4.10.1(4) Creating the imaging control program". Delete the 
global label "bImageCaptureTrig" created as the trigger of the imaging control. 
 

■When the master station is a MELSEC MX Controller 
Delete the imaging control program written in "4.10.2(4) Creating the imaging control program". Delete the 
global label "bImageCaptureTrig" created as the trigger of the imaging control. 
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4.15. Troubleshooting by Symptom 
This section describes the troubleshooting by symptom of issues encountered during the introduction procedure of 
MELSOFT VIMA. 
 

4.15.1. Unable to obtain or register a license 

No. Symptom Action 

1 The hardware code required to obtain 
the license file is not displayed. 

MELSOFT VIMA cannot be used on your personal computer. 
Install MELSOFT VIMA to a personal computer that satisfies the 
operating environment described in "3.3.1 Operating 
environment". 

2 The license cannot be registered. ・A file other than the MELSOFT VIMA license file or a license file 
with an altered file name or contents may have been selected. 
Use the correct license file. 

・A license key file created using the hardware code of another 
personal computer may have been selected. Check the 
registered license file and hardware code are correct. The 
hardware code of the license file can be checked with the file 
name of the license key file. 

 

4.15.2. Unable to set the network adapter 

No. Symptom Action 

1 The network adapter to be used is not 
displayed as a selectable item. 

・There may be no network adapter that is compatible with 
MELSOFT VIMA on your personal computer. Change the 
personal computer to the one equipped with an available 
network adapter. 

・Check that the target network adapter is recognized properly 
on your personal computer. If the network adapter is not 
recognized properly, reinstall its driver to ensure that it is 
recognized properly. 

・If a new network adapter is added after MELSOFT VIMA starts, 
restart MELSOFT VIMA. 

・When using a USB-to-LAN adapter, check that it is compatible 
with USB 3.0. This solution may not function properly if a USB-
to-LAN adapter that is not compatible with USB 3.0 is used. 
Replace it with the USB-to-LAN adapter that is compatible with 
USB 3.0. 

2 Application of the network adapter 
setting fails. 

If the personal computer has not been restarted after installing 
MELSOFT VIMA, restart the personal computer. 
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No. Symptom Action 

3 The IP address displayed when the 
network adapter is selected is different 
from the expected setting value. 

・The network adapter may not be connected to the network. 
If it is not connected to the network, an IP address may be 
automatically assigned and displayed in MELSOFT VIMA 
regardless of the network adapter setting. Review the 
connection of the network adapter to check that it is properly 
connected to the network, and then restart MELSOFT VIMA. 

・Multiple IP addresses may be set on the network adapter. 
If multiple IP addresses are set, the expected setting value will 
not be displayed and another IP address may be displayed. 
Check the name of the network adapter to be used, and set the 
correct IP address on it. If it does not operate correctly, set only 
one IP address on the network adapter. 

 

 
 

For issues other than the above or for troubleshooting problems occurring with each device, refer to the 
following. 
• Critical Moments Analytics Solution User's Manual (Troubleshooting of devices that are added for MELSOFT 

VIMA and the solution) 
• GX Works3 Operating Manual (Troubleshooting of GX Works3) 
• User's manuals of programmable controllers (Troubleshooting of programmable controllers used in the 

solution) 
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5. UNINSTALLATION PROCEDURE OF MELSOFT VIMA 
The following shows the uninstallation procedure of MELSOFT VIMA. 
 

1. Double-click the MELSOFT VIMA installer "setup.exe". 
Or, select "MELSOFT VIMA" from the list in "Programs and Features" to perform uninstallation. 

2. When the uninstallation confirmation dialog box appears, click the [Yes] button. 

 

 
The following dialog box appears when MELSOFT VIMA is running. Click the [OK] button to exit MELSOFT 
VIMA. 

 
 

3. The following window appears when the uninstallation is complete. 
Select whether to restart the personal computer, and then click the [Finish] button. 

 

4. When "Yes, I want to restart my computer now." is selected in Step 3, the personal computer automatically restarts. 
When "No, I will restart my computer later." is selected, restart the personal computer. 

 
Project files and collection files saved with MELSOFT VIMA are not deleted during uninstallation. 
Manage these files yourself and delete them when they are no longer needed or when disposing of the personal 
computer. 
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App 1 Open-Source Software 
MELSOFT VIMA consists of multiple software components. Our company or a third party holds copyright of each 
component. 
Open-source software incorporated in MELSOFT VIMA and its conditions are listed in a file in the installation folder. 
Example: 
Location of the file when the standard installation folder is selected 
• C:¥Program Files¥MELSOFT¥VIMA¥Doc¥Licenses¥ 
Our company's or other companies' software is not subject to source code distribution. 
Please refrain from inquiries regarding the content of open-source software source code. 
 
 



Critical Moments Analytics Solution Introduction Guide 

 

 106 / 106  
BCN-89796-0228-A 

REVISIONS 
Revision date No. Description 

April 2026 BCN-89796-0228-A First edition 

 

INFORMATION AND SERVICES 
For further information and services, please contact your local Mitsubishi Electric sales office or representative. 
Visit our website to find our locations worldwide. 
 
MITSUBISHI ELECTRIC Factory Automation Global Website 
Locations Worldwide 
www.MitsubishiElectric.com/fa/about-us/overseas/ 
 

TRADEMARKS 
• Windows is a trademark of the Microsoft group of companies. 
• Intel and Intel Core are registered trademarks or trademarks of Intel Corporation in the United States and other 

countries. 
• The company names, system names, and product names mentioned in this manual are either registered trademarks 

or trademarks of their respective companies. 
• In some cases, trademark symbols such as '™' or '®' are not specified in this manual. 
 

COPYRIGHT 
For the open-source software used in MELSOFT VIMA, refer to the "App 1 Open-Source Software". 
 
 





Specifications subject to change without notice.

When exported from Japan, this manual does not require application to the
Ministry of Economy, Trade and Industry for service transaction permission.

HEAD OFFICE: TOKYO BLDG., 2-7-3, MARUNOUCHI, CHIYODA-KU, TOKYO 100-8310, JAPAN
NAGOYA WORKS: 1-14, YADA-MINAMI 5-CHOME, HIGASHI-KU, NAGOYA 461-8670, JAPAN
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